Bug 971770 - Packstack fails to install quantum completely on all nodes when using linuxbridge.
Packstack fails to install quantum completely on all nodes when using linuxbr...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Linux
medium Severity medium
: Upstream M2
: 4.0
Assigned To: Terry Wilson
Ofer Blaut
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 04:57 EDT by Jaroslav Henner
Modified: 2013-12-19 19:05 EST (History)
9 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.1.dev691.el6ost
Doc Type: Bug Fix
Doc Text:
In previous releases, packstack did not support Linuxbridge. This prevented packstack from correctly installing quantum when specifying the 'linuxbridge' plugin. This release adds Linuxbridge support to packstack, thereby addressing the issue.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:05:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
answfile (9.37 KB, text/plain)
2013-06-07 04:57 EDT, Jaroslav Henner
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 34816 None None None Never
OpenStack gerrit 35847 None None None Never
Red Hat Product Errata RHEA-2013:1859 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2013-12-20 19:01:48 EST

  None (edit)
Description Jaroslav Henner 2013-06-07 04:57:36 EDT
Created attachment 758062 [details]
answfile

Description of problem:

`--> ssh folsom-rhel6.lithium ls /etc/init.d | grep quantum
# EMPTY HERE
`--> ssh node-01.lithium ls /etc/init.d | grep quantum 
# EMPTY HERE
`--> ssh node-02.lithium ls /etc/init.d | grep quantum 
# EMPTY HERE

Version-Release number of selected component (if applicable):
openstack-packstack-2013.1.1-0.10.dev605.el6ost.noarch

How reproducible:
always

Steps to Reproduce:
1. deploy using attached answfile
2.
3.

Actual results:
no quantum

Expected results:
some quantum

Additional info:
Comment 2 Terry Wilson 2013-06-28 14:13:09 EDT
There are fixes required for both packstack and the upstream puppet-quantum module. I have added an external tracker for the puppet fix. As soon as it is accepted, I can add the packstack fix.

BUT! Even when these fixes go in, the answer-file provided will fail because the VLAN_RANGES=8:64 is in the wrong format. It should be something like "physnet1:8:64". So when testing, make sure to fix that.
Comment 9 errata-xmlrpc 2013-12-19 19:05:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.