Bug 971781 - [RHS-C] Traceback "SSLError: [Errno 1] _ssl.c:490: error:14094416:SSL routines:SSL3_READ_BYTES:sslv3 alert certificate unknown" in vdsm logs
[RHS-C] Traceback "SSLError: [Errno 1] _ssl.c:490: error:14094416:SSL routine...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: vdsm (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Timothy Asir
Prasanth
infra
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 05:20 EDT by Prasanth
Modified: 2015-05-15 14:21 EDT (History)
11 users (show)

See Also:
Fixed In Version: CB3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:29:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm logs (11.58 MB, text/x-log)
2013-06-07 05:20 EDT, Prasanth
no flags Details

  None (edit)
Description Prasanth 2013-06-07 05:20:27 EDT
Created attachment 758082 [details]
vdsm logs

Description of problem:

Traceback "SSLError: [Errno 1] _ssl.c:490: error:14094416:SSL routines:SSL3_READ_BYTES:sslv3 alert certificate unknown" in vdsm logs

-----
SSLError: [Errno 1] _ssl.c:490: error:14094416:SSL routines:SSL3_READ_BYTES:sslv3 alert certificate unknown
Thread-136311::ERROR::2013-06-06 21:15:20,042::SecureXMLRPCServer::77::root::(handle_error) client ('10.70.36.27', 57859)
Traceback (most recent call last):
  File "/usr/lib64/python2.6/SocketServer.py", line 560, in process_request_thread
    self.finish_request(request, client_address)
  File "/usr/lib64/python2.6/site-packages/vdsm/SecureXMLRPCServer.py", line 68, in finish_request
    request.do_handshake()
  File "/usr/lib64/python2.6/ssl.py", line 279, in do_handshake
    self._sslobj.do_handshake()
SSLError: [Errno 1] _ssl.c:490: error:14094416:SSL routines:SSL3_READ_BYTES:sslv3 alert certificate unknown
Thread-136313::ERROR::2013-06-06 21:15:23,083::SecureXMLRPCServer::77::root::(handle_error) client ('10.70.36.27', 45386)
Traceback (most recent call last):
  File "/usr/lib64/python2.6/SocketServer.py", line 560, in process_request_thread
    self.finish_request(request, client_address)
  File "/usr/lib64/python2.6/site-packages/vdsm/SecureXMLRPCServer.py", line 68, in finish_request
    request.do_handshake()
  File "/usr/lib64/python2.6/ssl.py", line 279, in do_handshake
    self._sslobj.do_handshake()
SSLError: [Errno 1] _ssl.c:490: error:14094416:SSL routines:SSL3_READ_BYTES:sslv3 alert certificate unknown
-----


Version-Release number of selected component (if applicable):  Red Hat Storage Console Version: 2.1.0-0.bb2.el6rhs 


How reproducible: Always 


Steps to Reproduce:
1. Check the vdsm logs
2.
3.

Actual results: Traceback is seen in the vdsm logs


Expected results:


Additional info: vdsm logs attached
Comment 2 Prasanth 2013-06-28 03:16:09 EDT
VDSM version: vdsm-4.10.2-22.2.el6rhs.x86_64.rpm
Comment 3 Timothy Asir 2013-10-07 08:04:54 EDT
I am unable to reproduce this issue.
Could you please mention the exact steps to reproduce!
Comment 4 Prasanth 2013-10-08 05:10:32 EDT
(In reply to Timothy Asir from comment #3)
> I am unable to reproduce this issue.
> Could you please mention the exact steps to reproduce!

As I already discussed, there are no such steps to reproduce this issue as such. This traceback was seen in vdsm.log during my testing on "Red Hat Storage Console Version: 2.1.0-0.bb2.el6rhs" every-time after adding a host to the engine. This was always reproducible in that build. vdsm.log is already attached to this bug for any further debugging.

If you are sure that this got fixed by some of the patches that went into the latest releases, please move the bug to ON_QA with the Fixed_in_Version so that I would be able to verify the same?


Meanwhile, I can also check the same in CB3 build once that is out for testing.
Comment 5 Prasanth 2013-10-11 05:13:29 EDT
This Traceback is not seen with the latest build; cb3. Hence marking it as Verified.
Comment 7 errata-xmlrpc 2014-02-25 02:29:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.