Bug 9718 - variable $LINGUAS used before defined in /etc/profile.d/lang.csh
variable $LINGUAS used before defined in /etc/profile.d/lang.csh
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-23 10:35 EST by corth
Modified: 2014-03-16 22:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-23 13:00:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description corth 2000-02-23 10:35:43 EST
/etc/profile.d/lang.csh

crashes .login execution for csh style logins at this line:

    if ($LINGUAS == $LANG) then

due to undefined variable LINGUAS.

This is a fresh install.  I haven't played with language support at all.
Irritating but pretty easy to fix.

Chris
Comment 1 Chris Seawood 2000-02-23 12:57:59 EST
I also ran into this problem. I'm guessing this should've been set in /etc/sysconfig/i18n but what modifies that file? linuxconf?
Comment 2 Bill Nottingham 2000-02-23 13:00:59 EST
Fixed in the current rawhide initscripts.

Note You need to log in before you can comment on or make changes to this bug.