Bug 971807 - Better rsyslog support
Better rsyslog support
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sblim-cmpi-syslog (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 06:18 EDT by Tomáš Bžatek
Modified: 2015-03-03 18:06 EST (History)
2 users (show)

See Also:
Fixed In Version: sblim-cmpi-syslog-0.8.0-10.20120315cvs.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-23 23:34:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use internal memory array for Syslog_MessageLog values (3.25 KB, patch)
2013-06-07 06:21 EDT, Tomáš Bžatek
no flags Details | Diff
Parse rsyslog includes (3.21 KB, patch)
2013-06-07 06:23 EDT, Tomáš Bžatek
no flags Details | Diff
Parse rsyslog includes for Syslog_Setting instances (2.02 KB, patch)
2013-06-10 07:50 EDT, Tomáš Bžatek
no flags Details | Diff
Add support for filter definitions (8.27 KB, patch)
2013-06-12 05:41 EDT, Tomáš Bžatek
no flags Details | Diff
Don't crash when calling a method with zero arguments (1.83 KB, patch)
2013-06-12 11:43 EDT, Tomáš Bžatek
no flags Details | Diff
Handle missing ConfInFile file gracefully (2.72 KB, patch)
2013-06-17 08:41 EDT, Tomáš Bžatek
no flags Details | Diff
Handle cross-filesystem rename (3.41 KB, patch)
2013-06-17 08:44 EDT, Tomáš Bžatek
no flags Details | Diff
Proper write support for rsyslog includes in Syslog_Setting (24.23 KB, patch)
2013-06-20 12:06 EDT, Tomáš Bžatek
no flags Details | Diff
Fix Syslog_Setting instance deletion (8.00 KB, patch)
2013-06-24 11:10 EDT, Tomáš Bžatek
no flags Details | Diff
Handle unset properties on method calls better (5.67 KB, patch)
2013-06-25 11:23 EDT, Tomáš Bžatek
no flags Details | Diff
Fix some compiler warnings (1.74 KB, patch)
2013-06-25 11:32 EDT, Tomáš Bžatek
no flags Details | Diff
Allow Syslog_Setting.Priority key to be empty string (3.44 KB, patch)
2013-06-26 10:41 EDT, Tomáš Bžatek
no flags Details | Diff
Handle cross-filesystem rename (3.45 KB, patch)
2013-07-01 11:02 EDT, Tomáš Bžatek
no flags Details | Diff

  None (edit)
Description Tomáš Bžatek 2013-06-07 06:18:11 EDT
I'm going to publish series of enhancement patches, bringing better support for rsyslog within the provider.
Comment 1 Tomáš Bžatek 2013-06-07 06:21:51 EDT
Created attachment 758102 [details]
Use internal memory array for Syslog_MessageLog values

This first patch is a basis for future enhancements. It parses all items for Syslog_MessageLog during Syslog_MessageLog_Begin_Enum() and stores the data in memory, contrary to using a temporary file. The temporary file approach is retained for the Syslog_LogRecord case where large amounts of data are not convenient to be stored in memory.
Comment 2 Tomáš Bžatek 2013-06-07 06:23:37 EDT
Created attachment 758114 [details]
Parse rsyslog includes

This second patch adds support for $IncludeConfig directives within the rsyslog.conf configuration file. This means adding proper support for separate config files in /etc/rsyslog.d/ directory, as we have in Fedora.
Comment 3 Tomáš Bžatek 2013-06-10 07:50:36 EDT
Created attachment 759163 [details]
Parse rsyslog includes for Syslog_Setting instances

First of series of patches to properly support rsysglog $IncludeConfig directive in Syslog_Setting classes.
Comment 4 Tomáš Bžatek 2013-06-12 05:41:29 EDT
Created attachment 760056 [details]
Add support for filter definitions

This to support filter-type rules such as

:msg, contains, "error" /var/log/error.log
Comment 5 Tomáš Bžatek 2013-06-12 11:43:38 EDT
Created attachment 760234 [details]
Don't crash when calling a method with zero arguments

Simple crasher fix
Comment 6 Tomáš Bžatek 2013-06-17 08:41:37 EDT
Created attachment 762019 [details]
Handle missing ConfInFile file gracefully

Small fix for a crasher found by having empty /etc/rsyslog.conf file.
Comment 7 Tomáš Bžatek 2013-06-17 08:44:48 EDT
Created attachment 762020 [details]
Handle cross-filesystem rename

This patch fixes the case of having temporary file on different filesystem than the target file, e.g. creating new Syslog_Setting instance resulting in writing new rules through a temporary file.
Comment 8 Tomáš Bžatek 2013-06-20 12:06:40 EDT
Created attachment 763500 [details]
Proper write support for rsyslog includes in Syslog_Setting

This patch fixes and enhances rule write support through Syslog_Setting instances. It's a bit large due to number of changes needed to be done.

The only thing I'm aware is broken (and was before) is removing a rule from multiple rule line. Removing single rules works fine. This is going to be addressed in the next patch.
Comment 9 Tomáš Bžatek 2013-06-24 11:10:18 EDT
Created attachment 764673 [details]
Fix Syslog_Setting instance deletion

This patch fixes instance deletion and brings more robustness wrt to rule string matching.
Comment 10 Tomáš Bžatek 2013-06-25 11:23:54 EDT
Created attachment 765149 [details]
Handle unset properties on method calls better

(In reply to Tomáš Bžatek from comment #5)
> Created attachment 760234 [details]
> Don't crash when calling a method with zero arguments
> 
> Simple crasher fix

The attached patch is a follow up on this one, further extending it.
Comment 11 Tomáš Bžatek 2013-06-25 11:32:34 EDT
Created attachment 765151 [details]
Fix some compiler warnings

Patch to fix some compiler warnings related to the patches I posted.
Comment 12 Tomáš Bžatek 2013-06-25 12:17:01 EDT
Filed upstream bugreport https://sourceforge.net/p/sblim/bugs/2645/
Comment 13 Tomáš Bžatek 2013-06-26 10:41:04 EDT
Created attachment 765626 [details]
Allow Syslog_Setting.Priority key to be empty string

One more patch to fix a problem with filter rules.
Comment 14 Tomáš Bžatek 2013-07-01 11:02:25 EDT
Created attachment 767429 [details]
Handle cross-filesystem rename

An updated patch fixing some compilation issues.
Comment 15 Fedora Update System 2013-07-01 11:11:22 EDT
sblim-cmpi-syslog-0.8.0-10.20120315cvs.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sblim-cmpi-syslog-0.8.0-10.20120315cvs.fc19
Comment 16 Fedora Update System 2013-07-01 20:34:43 EDT
Package sblim-cmpi-syslog-0.8.0-10.20120315cvs.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sblim-cmpi-syslog-0.8.0-10.20120315cvs.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12135/sblim-cmpi-syslog-0.8.0-10.20120315cvs.fc19
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2013-07-23 23:34:48 EDT
sblim-cmpi-syslog-0.8.0-10.20120315cvs.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.