Bug 971824 - [RHS-C] Gluster Hook Events is failing with the error "Error while executing action: Action 1: The Notification event is unsupported."
Summary: [RHS-C] Gluster Hook Events is failing with the error "Error while executing ...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc   
(Show other bugs)
Version: 2.1
Hardware: x86_64 Linux
high
medium
Target Milestone: ---
: ---
Assignee: Sahina Bose
QA Contact: Prasanth
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-07 10:49 UTC by Prasanth
Modified: 2013-09-23 22:25 UTC (History)
7 users (show)

Fixed In Version: bb4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 22:25:45 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of error (113.42 KB, image/png)
2013-06-07 10:49 UTC, Prasanth
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15712 None None None Never

Description Prasanth 2013-06-07 10:49:00 UTC
Created attachment 758133 [details]
screenshot of error

Description of problem:

[RHS-C] Gluster Hook Events is failing with the error "Error while executing action: Action 1:  The Notification event is unsupported."

Version-Release number of selected component (if applicable):  Red Hat Storage Console Version: 2.1.0-0.bb2.el6rhs 


How reproducible: Always


Steps to Reproduce:
1. Click on "Users"
2. Click on the sub-tab "Event Notifier" and click on "Manage Events"
3. Select the "Gluster Hook Events:" checkbox, enter the "Mail Recipient:" and click on OK

Actual results: Following errors are seen:

----
Error while executing action:

Action 1:

    The Notification event is unsupported.

Action 2:

    The Notification event is unsupported.

Action 3:

    The Notification event is unsupported.

Action 4:

    The Notification event is unsupported.

Action 5:

    The Notification event is unsupported.

Action 6:

    The Notification event is unsupported.
Action 7:

    The Notification event is unsupported.

Action 8:

    The Notification event is unsupported.

Action 9:

    The Notification event is unsupported.

Action 10:

    The Notification event is unsupported.

Action 11:

    The Notification event is unsupported.
----


Expected results: The action should be successful.


Additional info: The same error is seen when enabling some of the other events as well.

Screenshot is attached

Comment 2 Prasanth 2013-06-21 10:18:13 UTC
Verified as fixed in bb4

Comment 3 Scott Haines 2013-09-23 22:25:45 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html


Note You need to log in before you can comment on or make changes to this bug.