Bug 971895 - PHP cart now serves index.php in preference to index.html in PROD
PHP cart now serves index.php in preference to index.html in PROD
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 10:05 EDT by Clayton Coleman
Modified: 2015-05-14 19:21 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 00:18:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clayton Coleman 2013-06-07 10:05:25 EDT
My app before and after V2 has changed - it's a PHP app with all the content in index.html, but it still has an index.php.

aws2012-claytondev.rhcloud.com

Earlier (I believe immediately prior to this release) index.html was being served in favor of index.php.  Now, index.php is being served.

This may break an unspecified number of apps like mine - essentially reveal JS static pages built in the PHP cart, relying on index.html to be the default.

The workaround is to delete index.php, but we need to know how many users this has effected and potentially revert the behavior.
Comment 2 Meng Bo 2013-06-08 23:10:05 EDT
Checked on devenv-stage_369,

Both index.html and index.php can be detected when access the app home page for php app.

Move bug to verified.
Comment 3 Jianwei Hou 2013-06-09 04:52:27 EDT
Verified this with v2 -> v2 migration, since devenv-stage_365 ami is wiped out from EC2, have to upgrade from devenv-stage_353 to 369, migrate from v1 to v2. Recreate the bug manually and fix it with migration

Steps(after instance is upgraded to devenv-stage_369 and cartridges are migrated to v2):
add index.php and index.html files to php/ under app repo, make contents of two files different and identical
1. On node, modify the php/env/OPENSHIFT_PHP_IDENT , change value:
redhat:php:5.3:0.0.2 => redhat:php:5.3:0.0.1
2. Edit php/configuration/etc/conf.d/php.conf , set value as:
DirectoryIndex index.php
3. Restart app and access the url --> should get the index.php page
4. rhc-admin-migrate --version 2.0.28a
5. After migration is complete, ssh into gear, check the contents in php/configuration/etc/conf.d/php.conf
DirectoryIndex index.html index.php
6. Access app url

Result:
After step 6, get the index.html page

Note You need to log in before you can comment on or make changes to this bug.