Bug 971899 - TicketMonster (2.3.0.ER1) fails to deploy on EAP 6.1.0
Summary: TicketMonster (2.3.0.ER1) fails to deploy on EAP 6.1.0
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise WFK Platform 2
Classification: Retired
Component: TicketMonster (Show other bugs)
(Show other bugs)
Version: 2.3.0
Hardware: Unspecified Unspecified
unspecified
urgent
Target Milestone: CR1
: 2.3.0
Assignee: Marek Novotny
QA Contact: Oliver Kišš
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-07 14:11 UTC by Oliver Kišš
Modified: 2015-08-02 23:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 10:49:41 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (26.71 KB, text/x-log)
2013-06-07 14:11 UTC, Oliver Kišš
no flags Details

Description Oliver Kišš 2013-06-07 14:11:01 UTC
Created attachment 758172 [details]
server.log

Description of problem:
TicketMonster will not deploy on EAP (see server.log in attachment)

This seems to be caused by presence of weld-servlet jar in TicketMonster war file.

Deployment completes successfully if line 221 of TicketMonster pom.xml:

<artifactId>weld-servlet-core</artifactId>

is changed to

<artifactId>weld-servlet</artifactId>

and TicketMonster is rebuilt.


context (lines 213-228):
        <dependency>
            <groupId>org.jboss.errai</groupId>
            <artifactId>errai-weld-integration</artifactId>
            <exclusions>
                <exclusion>
                    <groupId>
                        org.jboss.weld.servlet
                    </groupId>
                    <artifactId>weld-servlet-core</artifactId>
                </exclusion>
                <exclusion>
                    <groupId>org.jboss.errai</groupId>
                    <artifactId>errai-cdi-jetty</artifactId>
                </exclusion>               
            </exclusions>
        </dependency>

Version-Release number of selected component (if applicable):
2.3.0.ER1

Comment 1 Marek Novotny 2013-06-10 11:22:20 UTC
fixed by suggested change from description by http://git.app.eng.bos.redhat.com/?p=wfk/ticket-monster.git;a=commitdiff;h=ee5c416f7db4cf83a3cf3b3ac7747a7cba2fbf8a

Comment 3 Oliver Kišš 2013-06-27 13:02:15 UTC
Verified in CR1


Note You need to log in before you can comment on or make changes to this bug.