Bug 971908 - Saving multiple assets in a single tab from BRM (Guvnor) throws "binaryUpToDate has been modified externally"
Saving multiple assets in a single tab from BRM (Guvnor) throws "binaryUpToDa...
Status: CLOSED NOTABUG
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
5.x.x
All All
high Severity high
: ---
: ---
Assigned To: manstis
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 10:33 EDT by Musharraf Hussain
Modified: 2013-11-18 07:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
JBoss Enterprise BRMS Platform 5.3.1
Last Closed: 2013-08-22 03:04:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker GUVNOR-2017 Major Resolved Saving multiple assets in a single tab from BRM (Guvnor) throws "binaryUpToDate has been modified externally" 2016-01-26 07:57 EST

  None (edit)
Description Musharraf Hussain 2013-06-07 10:33:44 EDT
Description of problem:


    If we try to save multiple rules opened in a single tab through BRM (i.e. Guvnor) it throws the error "binaryUpToDate has been modified externally" . As per the experts the saving of each asset will try to set the 'binaryUpToDate' attribute on the package item in which these assets belong to. This is the reason why we get "binaryUpToDate has been modified externally" for the second or all the following asset saving operations.

~~~
ERROR [RepositoryServiceServlet] Service method 'public abstract java.lang.String org.drools.guvnor.client.rpc.AssetService.checkinVersion(org.drools.guvnor.client.rpc.RuleAsset) throws com.google.gwt.user.client.rpc.SerializationException' threw an unexpected exception: org.drools.repository.RulesRepositoryException: Unable to checkin.
org.drools.repository.RulesRepositoryException: Unable to checkin.
at org.drools.repository.VersionableItem.checkin(VersionableItem.java:591)
at org.drools.guvnor.server.RepositoryAssetOperations.checkinVersion(RepositoryAssetOperations.java:141)
at org.drools.guvnor.server.RepositoryAssetService.checkinVersion(RepositoryAssetService.java:153)
...
Caused by: javax.jcr.InvalidItemStateException: Unable to update a stale item: item.save()
at org.apache.jackrabbit.core.ItemSaveOperation.perform(ItemSaveOperation.java:262)
at org.apache.jackrabbit.core.session.SessionState.perform(SessionState.java:200)
at org.apache.jackrabbit.core.ItemImpl.perform(ItemImpl.java:91)
at org.apache.jackrabbit.core.ItemImpl.save(ItemImpl.java:329)
...
Caused by: org.apache.jackrabbit.core.state.StaleItemStateException: da98caef-e1c4-4f98-880c-46a740c9131f/
{http://www.jboss.org/drools-repository/1.0}

binaryUpToDate has been modified externally
at org.apache.jackrabbit.core.state.SharedItemStateManager$Update.begin(SharedItemStateManager.java:663)
at org.apache.jackrabbit.core.state.SharedItemStateManager.beginUpdate(SharedItemStateManager.java:1458)
at org.apache.jackrabbit.core.state.SharedItemStateManager.update(SharedItemStateManager.java:1488)
...
~~~

    After this strangely, we can still see the assets are getting properly updated in BRM (i.e. Guvnor).



Version-Release number of selected component (if applicable):
- JBoss Enterprise BRMS Platform 5.3.1

How reproducible:
- Please follow the steps below to reproduce this issue

Steps to Reproduce:
1. Open multiple assets in a single tab
2. Save the assets in the editor by clicking "save all"
3.

Actual results:
- It throws the exception "binaryUpToDate has been modified externally"

Expected results:
- It should allow to save those multiple assets at one shot.

Additional info:
Comment 4 manstis 2013-08-02 09:33:21 EDT
See comment #2, not applicable to 6.0.x.
Comment 5 Prakash Aradhya 2013-08-06 15:56:05 EDT
This should nto be an issue in 6.0  Can QE double check this ?
Comment 6 Lukáš Petrovický 2013-08-22 03:04:52 EDT
No longer valid in 6.0.
Comment 7 JBoss JIRA Server 2013-11-18 07:02:31 EST
Michael Anstis <michael.anstis@gmail.com> updated the status of jira GUVNOR-2017 to Resolved

Note You need to log in before you can comment on or make changes to this bug.