Bug 971930 - /var/lib/samba should be listed in /etc/rwtab
/var/lib/samba should be listed in /etc/rwtab
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initscripts (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: initscripts Maintenance Team
Jan Ščotka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 11:35 EDT by Ales Zelinka
Modified: 2016-11-25 07:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:09:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Zelinka 2013-06-07 11:35:53 EDT
samba doesn't start when system is in readonly-root mode because it can't write into /var/lib/samba.

Please add "files /var/lib/samba" to rwtab.

from /var/log/samba/log.smbd:

[2013/06/07 14:23:31,  0] ../source3/smbd/server.c:1200(main)
  smbd version 4.0.2 started.
  Copyright Andrew Tridgell and the Samba Team 1992-2012
[2013/06/07 14:23:31,  2] ../lib/tdb_wrap/tdb_wrap.c:64(tdb_wrap_log)
  tdb(/var/lib/samba/messages.tdb): tdb_open_ex: could not open file /var/lib/samba/messages.tdb: Read-only file system
[2013/06/07 14:23:31,  2] ../source3/lib/messages_local.c:132(messaging_tdb_init)
  ERROR: Failed to initialise messages database: Read-only file system
[2013/06/07 14:23:31,  2] ../source3/lib/messages.c:203(messaging_init)
  messaging_tdb_init failed: NT_STATUS_ACCESS_DENIED

samba-4.0.2-1.el7.x86_64
initscripts-9.42.1-1.el7.x86_64
Comment 5 Ludek Smid 2014-06-13 08:09:49 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.