Bug 971934 - Portal navigation submenus don't hide on Apple devices
Portal navigation submenus don't hide on Apple devices
Status: CLOSED WONTFIX
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: Portal (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER02
: 6.1.0
Assigned To: Matt Wringe
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 11:47 EDT by Filip Kiss
Modified: 2013-11-04 19:56 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 03:15:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Kiss 2013-06-07 11:47:25 EDT
Description of problem:
When you tap on e.g. "Site", displayed submenu does not hide after tapping on a page. It only hides when Site is tapped again.

Additional info:
- iPad with iOS 5, iPhone 4 with iOS4
Comment 1 Matt Wringe 2013-06-11 16:19:14 EDT
Can you please clarify the issue here exactly? 

When you click 'site' you are toggling open the site menu, you need to click it again to close it or follow one of the links to another page. It is not meant to disappear if you click somewhere else on the page.
Comment 2 Filip Kiss 2013-06-12 04:34:10 EDT
Yes, if you click "Site" again, site menu disappears as expected. When I click  somewhere else on the page on android devices, site menu disappears too. I find it intuitive and more useful than tapping exactly on one spot ("Site" link), so I expected that this second option of closing submenu should work on all devices.
Comment 3 Matt Wringe 2013-06-17 10:53:11 EDT
I think this should be closed as WONTFIX.

Different mobile browsers handle touch events with virtual mice differently. With iOS in this case, there is no mouseleave/mouseout event when the user clicks somewhere else (while in the Android case there is).

I don't think this inconsistency is worth the effort and risk to change. Especially since the navigation submenu's are not really meant to be used often with mobile devices. The only time a non-administer would ever use it is when they are on the dashboard. Administration on mobile devices is not supported.

Note You need to log in before you can comment on or make changes to this bug.