Bug 971948 - [abrt] meld-1.7.3-1.fc19: historyentry.py:358:<lambda>:TypeError: <HistoryFileEntry object at 0x93db6e4 (HistoryFileEntry at 0x94d3810)>: unknown signal name: changed
[abrt] meld-1.7.3-1.fc19: historyentry.py:358:<lambda>:TypeError: <HistoryFil...
Status: CLOSED DUPLICATE of bug 888290
Product: Fedora
Classification: Fedora
Component: meld (Show other bugs)
19
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominic Hopf
Fedora Extras Quality Assurance
abrt_hash:48214afc8527af24455eb254931...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 12:18 EDT by Mikhail
Modified: 2014-03-23 14:13 EDT (History)
25 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-19 11:39:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (605 bytes, text/plain)
2013-06-07 12:18 EDT, Mikhail
no flags Details
File: environ (1.62 KB, text/plain)
2013-06-07 12:19 EDT, Mikhail
no flags Details
Error logs (2.47 KB, application/gzip)
2013-07-19 01:54 EDT, Devon Janitz
no flags Details
Move property and signal creation into _class_init() (10.83 KB, text/plain)
2013-08-06 03:19 EDT, Damian Wrobel
no flags Details
Error logs (2.40 KB, application/x-gzip)
2013-08-17 08:44 EDT, Devon Janitz
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 694108 None None None Never

  None (edit)
Description Mikhail 2013-06-07 12:18:53 EDT
Version-Release number of selected component:
meld-1.7.3-1.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        python /usr/bin/meld
core_backtrace: ab49178196614ef2e7ffdcb5c91d0d82b0b177a0 0x166 <lambda> /usr/share/meld/meld/ui/historyentry.py -
executable:     /usr/bin/meld
kernel:         3.9.4-301.fc19.i686.PAE
runlevel:       N 5
uid:            1000

Truncated backtrace:
historyentry.py:358:<lambda>:TypeError: <HistoryFileEntry object at 0x93db6e4 (HistoryFileEntry at 0x94d3810)>: unknown signal name: changed

Traceback (most recent call last):
  File "/usr/share/meld/meld/ui/historyentry.py", line 358, in <lambda>
    entry.connect("changed", lambda *args: self.emit("changed"))
TypeError: <HistoryFileEntry object at 0x93db6e4 (HistoryFileEntry at 0x94d3810)>: unknown signal name: changed

Local variables in innermost frame:
self: <HistoryFileEntry object at 0x93db6e4 (HistoryFileEntry at 0x94d3810)>
args: (<gtk.Entry object at 0x93de0f4 (GtkEntry at 0x94a1da0)>,)
Comment 1 Mikhail 2013-06-07 12:18:57 EDT
Created attachment 758231 [details]
File: backtrace
Comment 2 Mikhail 2013-06-07 12:19:01 EDT
Created attachment 758232 [details]
File: environ
Comment 3 Devon Janitz 2013-07-19 01:54:06 EDT
Created attachment 775640 [details]
Error logs

This is still a problem.  Just compared two files.
Devon
Comment 4 Andre Klapper 2013-07-24 00:42:07 EDT
Upstream: https://bugzilla.gnome.org/show_bug.cgi?id=701620
Comment 5 Tomas Dolezal 2013-07-24 19:53:32 EDT
Occured when running in `su root` environment with two file descriptors
Comment 6 Bruce-Robert Pocock 2013-08-05 16:18:16 EDT
Occurs consistently when doing "git mergetool" when quitting. Does not seem to matter whether I'm doing a save-during-quit or not.
Comment 7 Damian Wrobel 2013-08-06 03:19:51 EDT
Created attachment 783214 [details]
Move property and signal creation into _class_init()

This is a backport of commit efcb0f9fd for 2.28.x. This allows old pygtk
applications to work with pygobject 2.28.x and glib 2.35.x.

Reference: http://archive.ubuntu.com/ubuntu/pool/main/p/pygobject-2/pygobject-2_2.28.6.orig.tar.bz2 //debian/patches/00git_class_init.patch
Comment 8 Damian Wrobel 2013-08-06 03:23:03 EDT
Aforementioned patch applied to pygobject2-2.28.6-9 fixes the issue for me.
Comment 9 Pablo Rodríguez 2013-08-13 14:35:29 EDT
(In reply to Damian Wrobel from comment #8)
> Aforementioned patch applied to pygobject2-2.28.6-9 fixes the issue for me.

I’m afraid I’m still experiencing the issue after that update.
Comment 10 markusN 2013-08-17 07:19:03 EDT
Same issue when comparing two ASCII files. F19 system, 'yum update'd yesterday.
Comment 11 Devon Janitz 2013-08-17 08:40:57 EDT
Mine is still throwing an error as well, no changes.
Comment 12 Devon Janitz 2013-08-17 08:44:11 EDT
Created attachment 787549 [details]
Error logs

New errror logs encase the error has changed from time.
Thanks, Devon
Comment 13 Damian Wrobel 2013-08-17 17:06:28 EDT
(In reply to Pablo Rodríguez from comment #9)
> (In reply to Damian Wrobel from comment #8)
> > Aforementioned patch applied to pygobject2-2.28.6-9 fixes the issue for me.
> 
> I’m afraid I’m still experiencing the issue after that update.

The pygobject2-2.28.6-9 package doesn't contain any fixes for that issue, you need to manually apply the patch mentioned in the comment #7 and rebuild the package to get rid of this issue.
Comment 14 Michael Cronenworth 2013-08-19 11:39:16 EDT

*** This bug has been marked as a duplicate of bug 888290 ***

Note You need to log in before you can comment on or make changes to this bug.