Bug 971962 - mapper: dependency issue with GraphViz
mapper: dependency issue with GraphViz
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnssec-tools (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Wes Hardaker
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 13:51 EDT by Christian Stadelmann
Modified: 2013-07-25 20:29 EDT (History)
1 user (show)

See Also:
Fixed In Version: dnssec-tools-1.14-7.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-25 20:29:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of $ mapper (1.50 KB, text/plain)
2013-06-07 13:51 EDT, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2013-06-07 13:51:26 EDT
Created attachment 758257 [details]
output of $ mapper

Description of problem:
mapper requires GraphViz, GraphViz::Small and GraphViz::No which are no dependencies of the dnssec-tools package 

Version-Release number of selected component (if applicable):
dnssec-tools: 1.14

How reproducible:
Always

Steps to Reproduce:
1. install dnssec-tools
2. start mapper

Actual results:
mapper should start fine

Expected results:
mapper does not start. Output attached.

Additional info:
perl-GraphViz provides the required perl modules.
Comment 1 Wes Hardaker 2013-06-20 18:58:00 EDT
This was sort of by design based on other opinions.  Some of the applications in DNSSEC-Tools are optional and thus by not requiring everything be installed you save the installation footprint a bit if you didn't need, say, mapper.

That being said I've always thought that line of thinking was pseudo-silly on a system with pre-built packages.  So I'll add GraphViz back to the requires list and point at this bug if someone complains :-)
Comment 2 Fedora Update System 2013-06-20 20:25:19 EDT
dnssec-tools-1.14-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/dnssec-tools-1.14-7.fc18
Comment 3 Fedora Update System 2013-06-23 01:53:46 EDT
Package dnssec-tools-1.14-7.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnssec-tools-1.14-7.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11484/dnssec-tools-1.14-7.fc18
then log in and leave karma (feedback).
Comment 4 Christian Stadelmann 2013-07-01 18:58:09 EDT
Works for me. But how about splitting mapper (and possibly others) to another package it they have too much dependencies?
Comment 5 Wes Hardaker 2013-07-02 13:26:23 EDT
I could, but I think I'll try it like this now.  There are some systems where GraphViz and some other tools aren't available (RHEL systems don't have everything needed), so I didn't include requirement for those systems.
Comment 6 Fedora Update System 2013-07-25 20:29:26 EDT
dnssec-tools-1.14-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.