Bug 971983 - orphan remove does not remove isos from the filesystem
orphan remove does not remove isos from the filesystem
Status: CLOSED DUPLICATE of bug 952386
Product: Pulp
Classification: Community
Component: z_other (Show other bugs)
2.2 Beta
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sayli Karmarkar
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-07 14:31 EDT by Preethi Thomas
Modified: 2015-03-22 21:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 13:52:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2013-06-07 14:31:04 EDT
Description of problem:

If you delete an iso repo, orphan list lists the iso from the deleted repo and orphan remove seems to be running successfully, but if you check the filesystem.

Version-Release number of selected component (if applicable):
[root@hp-dl360g6-01 ~]# rpm -q pulp-server
pulp-server-2.2.0-0.2.beta.fc18.noarch
[root@hp-dl360g6-01 ~]# 


How reproducible:


Steps to Reproduce:
[root@hp-dl360g6-01 ~]# rm -rf /var/lib/pulp/content/iso/*
[root@hp-dl360g6-01 ~]# ls -l /var/lib/pulp/content/iso/
total 0
[root@hp-dl360g6-01 ~]# 
[root@hp-dl360g6-01 ~]# 
[root@hp-dl360g6-01 ~]# 
[root@hp-dl360g6-01 ~]# pulp-admin iso repo create  --repo-id iso.repo --feed http://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/test_file_repo/
Successfully created repository [iso.repo]

[root@hp-dl360g6-01 ~]# pulp-admin iso repo sync run --repo-id iso.repo
+----------------------------------------------------------------------+
                  Synchronizing Repository [iso.repo]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading the Pulp Manifest...
The Pulp Manifest was downloaded successfully.

Downloading 3 ISOs...
[==================================================] 100%
ISOs: 3/3	Data: 10.2 MB/10.2 MB	Avg: 1.7 MB/s


Successfully downloaded 3 ISOs.

The repository was successfully published.

[root@hp-dl360g6-01 ~]# ls -l /var/lib/pulp/content/iso/total 12
drwxr-xr-x. 3 apache apache 4096 Jun  7 14:19 test2.iso
drwxr-xr-x. 3 apache apache 4096 Jun  7 14:19 test3.iso
drwxr-xr-x. 3 apache apache 4096 Jun  7 14:19 test.iso
[root@hp-dl360g6-01 ~]# 
[root@hp-dl360g6-01 ~]# 
[root@hp-dl360g6-01 ~]# pulp-admin orphan list+----------------------------------------------------------------------+
                                Summary
+----------------------------------------------------------------------+

Distribution:      0
Drpm:              0
Erratum:           0
Iso:               0
Package Category:  0
Package Group:     0
Puppet Module:     0
Rpm:               0
Srpm:              0
Total:             0


[root@hp-dl360g6-01 ~]#  pulp-admin iso repo delete  --repo-id iso.repo
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...

[-]
Running...

Repository [iso.repo] successfully deleted


[root@hp-dl360g6-01 ~]# pulp-admin orphan list+----------------------------------------------------------------------+
                                Summary
+----------------------------------------------------------------------+

Distribution:      0
Drpm:              0
Erratum:           0
Iso:               3
Package Category:  0
Package Group:     0
Puppet Module:     0
Rpm:               0
Srpm:              0
Total:             3


[root@hp-dl360g6-01 ~]# pulp-admin orphan remove --allRequest accepted

check status of task 14f26a39-6032-40e4-bc2d-e3299d66771c with "pulp-admin tasks
details"
[root@hp-dl360g6-01 ~]# pulp-admin orphan list
+----------------------------------------------------------------------+
                                Summary
+----------------------------------------------------------------------+

Distribution:      0
Drpm:              0
Erratum:           0
Iso:               0
Package Category:  0
Package Group:     0
Puppet Module:     0
Rpm:               0
Srpm:              0
Total:             0


[root@hp-dl360g6-01 ~]# ls -l /var/lib/pulp/content/iso/
total 12
drwxr-xr-x. 3 apache apache 4096 Jun  7 14:19 test2.iso
drwxr-xr-x. 3 apache apache 4096 Jun  7 14:19 test3.iso
drwxr-xr-x. 3 apache apache 4096 Jun  7 14:19 test.iso
[root@hp-dl360g6-01 ~]# 

Actual results:

iso files not removed from the filesystm

Expected results:


Additional info:
Comment 1 Preethi Thomas 2013-06-12 13:42:30 EDT
Moving it back to asigned

I tested it again. so files does get deleted from /var/lib/pulp/content/iso/

but if you look in /var/lib/pulp/published/https/isos/

you can see that pulp-manifest still exist there and also the symlinks to iso which are already deleted

[root@hp-dl360g6-01 ~]# pulp-admin iso repo create --repo-id iso-repo --feed http://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/test_file_repo/
Successfully created repository [iso-repo]

[root@hp-dl360g6-01 ~]# pulp-admin iso repo sync run --repo-id iso-repo 
+----------------------------------------------------------------------+
                  Synchronizing Repository [iso-repo]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading the Pulp Manifest...
The Pulp Manifest was downloaded successfully.

Downloading 3 ISOs...
[==================================================] 100%
ISOs: 3/3	Data: 10.2 MB/10.2 MB	Avg: 1.0 MB/s


Successfully downloaded 3 ISOs.

The repository was successfully published.

[root@hp-dl360g6-01 ~]# pulp-admin orphan list
+----------------------------------------------------------------------+
                                Summary
+----------------------------------------------------------------------+

Distribution:      0
Drpm:              0
Erratum:           0
Iso:               0
Package Category:  0
Package Group:     0
Puppet Module:     0
Rpm:               0
Srpm:              0
Total:             0


[root@hp-dl360g6-01 ~]# ls -l /var/lib/pulp/content/iso/
total 12
drwxr-xr-x. 3 apache apache 4096 Jun 12 13:35 test2.iso
drwxr-xr-x. 3 apache apache 4096 Jun 12 13:35 test3.iso
drwxr-xr-x. 3 apache apache 4096 Jun 12 13:35 test.iso
[root@hp-dl360g6-01 ~]# ls -l /var/lib/pulp/content/iso/test2.iso/042c259d546331588e1dff83a46f62a27fb7cf3de4050924470d99fd8d2a046f/4358144/
total 4256
-rw-r--r--. 1 apache apache 4358144 Jun 12 13:35 test2.iso
[root@hp-dl360g6-01 ~]# 
[root@hp-dl360g6-01 ~]# pulp-admin iso repo delete --repo-id iso-repo
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...

[-]
Running...

Repository [iso-repo] successfully deleted


[root@hp-dl360g6-01 ~]# pulp-admin orphan list
+----------------------------------------------------------------------+
                                Summary
+----------------------------------------------------------------------+

Distribution:      0
Drpm:              0
Erratum:           0
Iso:               3
Package Category:  0
Package Group:     0
Puppet Module:     0
Rpm:               0
Srpm:              0
Total:             3


[root@hp-dl360g6-01 ~]# pulp-admin orphan remove --all
Request accepted

check status of task e9920078-af01-46f7-bf49-761bad69270a with "pulp-admin tasks
details"
[root@hp-dl360g6-01 ~]# pulp-admin orphan list
+----------------------------------------------------------------------+
                                Summary
+----------------------------------------------------------------------+

Distribution:      0
Drpm:              0
Erratum:           0
Iso:               0
Package Category:  0
Package Group:     0
Puppet Module:     0
Rpm:               0
Srpm:              0
Total:             0


[root@hp-dl360g6-01 ~]# ls -l /var/lib/pulp/content/iso/
total 12
drwxr-xr-x. 3 apache apache 4096 Jun 12 13:35 test2.iso
drwxr-xr-x. 3 apache apache 4096 Jun 12 13:35 test3.iso
drwxr-xr-x. 3 apache apache 4096 Jun 12 13:35 test.iso
[root@hp-dl360g6-01 ~]# ls -l /var/lib/pulp/content/iso/test2.iso/042c259d546331588e1dff83a46f62a27fb7cf3de4050924470d99fd8d2a046f/4358144/
total 0
[root@hp-dl360g6-01 ~]# ls -l /var/lib/pulp/content/iso/test
test2.iso/ test3.iso/ test.iso/  
[root@hp-dl360g6-01 ~]# ls -l /var/lib/pulp/content/iso/test.iso/582f1729b0c15eacbb7d02a553c0a96a39f817135c15ac4190aef96e45c4b65d/3145728/
total 0
[root@hp-dl360g6-01 ~]# ls -l /var/lib/pulp/published/http
http/  https/ 
[root@hp-dl360g6-01 ~]# ls -l /var/lib/pulp/published/https/
isos/  repos/ 
[root@hp-dl360g6-01 ~]# ls -l /var/lib/pulp/published/https/isos/iso-repo/
PULP_MANIFEST  test2.iso      test3.iso      test.iso       
[root@hp-dl360g6-01 ~]# ls -l /var/lib/pulp/published/https/isos/iso-repo/
total 16
-rw-r--r--. 1 apache apache 251 Jun 12 13:35 PULP_MANIFEST
lrwxrwxrwx. 1 apache apache 118 Jun 12 13:35 test2.iso -> /var/lib/pulp/content/iso/test2.iso/042c259d546331588e1dff83a46f62a27fb7cf3de4050924470d99fd8d2a046f/4358144/test2.iso
lrwxrwxrwx. 1 apache apache 118 Jun 12 13:35 test3.iso -> /var/lib/pulp/content/iso/test3.iso/f56e08898287e60b3169392351e9296bbe28417db1f8e34e8058d124be89b93a/3244032/test3.iso
lrwxrwxrwx. 1 apache apache 116 Jun 12 13:35 test.iso -> /var/lib/pulp/content/iso/test.iso/582f1729b0c15eacbb7d02a553c0a96a39f817135c15ac4190aef96e45c4b65d/3145728/test.iso
Comment 2 Randy Barlow 2013-06-12 13:52:56 EDT
This is already reported: https://bugzilla.redhat.com/show_bug.cgi?id=952386

*** This bug has been marked as a duplicate of bug 952386 ***

Note You need to log in before you can comment on or make changes to this bug.