Bug 97199 - bugzilla let me make public bug private with random user on CC list
bugzilla let me make public bug private with random user on CC list
Status: CLOSED NOTABUG
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-11 10:08 EDT by Jonathan Kamens
Modified: 2013-06-23 23:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-02 16:05:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2003-06-11 10:08:07 EDT
I just added a comment to bug 87606: "This is still broken in
imap-2002b-6.  Surely you can't ship the next release with this still
broken!"  Because I mentioned the next release, I clicked the box to
make the bug private before committing my changes.  I noticed that
when I subsequently committed my changes, E-mail about them was sent
to someone on the CC list of the bug.

It appears that if a bug is converted from public to private, people
who added themselves to the CC list before the conversion will
continue to receive E-mail about the bug, and said E-mail may contain
private information.

This seems like a problem.
Comment 1 David Lawrence 2006-04-08 13:52:17 EDT
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.
Comment 2 David Lawrence 2007-11-02 16:05:23 EDT
The Cc list accessible checkbox needs to be unchecked when making the group
change, otherwise this will occur. This is a Bugzilla design issue and is best
addressed with the upstream community at http://www.bugzilla.org.

Note You need to log in before you can comment on or make changes to this bug.