Bug 972280 - [whql][vioser]Plug and Play job failed on win2k3-32
[whql][vioser]Plug and Play job failed on win2k3-32
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Gal Hammer
Virtualization Bugs
: Reopened, TestBlocker
: 972383 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-08 02:15 EDT by Min Deng
Modified: 2014-07-11 02:23 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 972380 (view as bug list)
Environment:
Last Closed: 2014-01-27 04:16:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Min Deng 2013-06-08 02:15:04 EDT
Description of problem:
The job named plug and play failed on both win2k3-32 and win2k3-64 OS.
Though QE disable S3 and S4 support it still failed.

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-64

How reproducible:
5 times failed 5 times
Steps to Reproduce:
1./usr/libexec/qemu-kvm -M rhel6.4.0 -m 2G -smp 4 -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -drive file=win2k3-32-serial.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device e1000,netdev=hostnet0,mac=00:14:36:35:41:31,id=net0 -uuid 578323c7-bf16-4ff7-8335-ae51f3c2f7da -rtc-td-hack -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2k3-32-serial,server,nowait -mon chardev=111a,mode=readline -name win2k3-64 -vnc :1 -device virtio-serial-pci,id=virtio-serial0,max_ports=16,vectors=4,bus=pci.0 -chardev pty,id=channel0 -device virtserialport,chardev=channel0,name=org.linux-kvm.port.0,bus=virtio-serial0.0 -vga cirrus -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=1
2.submit the job

Actual results:
  The job failed while enabling s3/s4 on both win2k3-32 and win2k3-64 OS
The job still failed if disabling  S3 and S4,but win2k3-64 got BSOD.

Expected results:
The job can pass successfully.

Additional info:
We could not filter the issue with manual errata #1019 either.So I report it.The related logs and dump files will be uploaded after a while.thanks
Comment 3 Min Deng 2013-06-08 02:32:19 EDT
Created attachment 758464 [details]
win2k3-32
Comment 4 Min Deng 2013-06-08 02:34:42 EDT
Created attachment 758465 [details]
win2k3-64
Comment 6 Mike Cao 2013-06-08 23:07:55 EDT
As win2k3-32/64 has different behavior ,I would like to use this bug to track win2k3-32 job failed issue ,Pls report a new bug about win2k3-64 guest BSOD issue
Comment 7 Gal Hammer 2013-06-09 11:47:59 EDT
I run the plug and play test on a guest running Windows 2003 SP2 with all updates installed and I didn't get a BSOD (although the test fails).

Can you please re-run the test on an updated Windows 2003 guest as well and tell me your results?

Thanks, Gal.
Comment 8 Gal Hammer 2013-06-10 02:10:30 EDT
*** Bug 972383 has been marked as a duplicate of this bug. ***
Comment 11 Mike Cao 2013-06-23 09:38:38 EDT
As It still exists ,It's better to proposed to RHEL6.6.0 ,Re-open it
Comment 12 Mike Cao 2013-07-01 05:49:17 EDT
QE retest this issue on hck w/ virtio-win-prewhql-49 

Actual Results:
guest bosd with c4 error code so that I can not determine whether it is a regression
Comment 13 Gal Hammer 2013-08-11 07:26:02 EDT
(In reply to Mike Cao from comment #12)
> QE retest this issue on hck w/ virtio-win-prewhql-49 
> 
> Actual Results:
> guest bosd with c4 error code so that I can not determine whether it is a
> regression

C4 is driver verifier error and it is not the reason for the current failure. I wouldn't say that this is a regression.
Comment 14 Gal Hammer 2014-01-23 02:00:29 EST
Mike, is this bug is still relevant if testing using WLK (and not HCK)? Thanks.
Comment 15 Mike Cao 2014-01-23 21:54:50 EST
(In reply to Gal Hammer from comment #14)
> Mike, is this bug is still relevant if testing using WLK (and not HCK)?
> Thanks.

Retest this issue on virtio-win-prewhql-74 on RHEL6.5 host 

Can not reproduce this issue ,Feel free to close it 


Thanks,
Mike
Comment 16 Gal Hammer 2014-01-27 04:16:06 EST
Closing based on comment #15.

HCK tests should not be used to certificate for Windows 2003.

Note You need to log in before you can comment on or make changes to this bug.