Bug 972285 - [abrt] system-config-services-0.101.9-1.fc18: system-config-services:47:<module>:ImportError: No module named gui
[abrt] system-config-services-0.101.9-1.fc18: system-config-services:47:<modu...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
abrt_hash:22fcdbb850a6fa28a796abf3733...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-08 02:43 EDT by Fabien Archambault
Modified: 2013-06-10 07:11 EDT (History)
1 user (show)

See Also:
Fixed In Version: system-config-services-0.101.10-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 972661 (view as bug list)
Environment:
Last Closed: 2013-06-10 07:11:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (892 bytes, text/plain)
2013-06-08 02:43 EDT, Fabien Archambault
no flags Details
File: environ (2.31 KB, text/plain)
2013-06-08 02:43 EDT, Fabien Archambault
no flags Details

  None (edit)
Description Fabien Archambault 2013-06-08 02:43:40 EDT
Description of problem:
Updating system with yum

Version-Release number of selected component:
system-config-services-0.101.9-1.fc18

Additional info:
cmdline:        /usr/bin/python /sbin/system-config-services
core_backtrace: 65096fc6557efe46b4d34e7b7e710af65fbe83b7 0x2f <module> /sbin/system-config-services -
executable:     /sbin/system-config-services
kernel:         3.8.11-200.fc18.i686.PAE
uid:            0

Truncated backtrace:
system-config-services:47:<module>:ImportError: No module named gui

Traceback (most recent call last):
  File "/sbin/system-config-services", line 47, in <module>
    from scservices.gui import UIController
ImportError: No module named gui

Local variables in innermost frame:
GPollableInputStream: <class 'gio.__main__.GPollableInputStream'>
__builtins__: <module '__builtin__' (built-in)>
__file__: '/sbin/system-config-services'
gettext: <module 'gettext' from '/usr/lib/python2.7/gettext.pyc'>
__package__: None
sys: <module 'sys' (built-in)>
locale: <module 'locale' from '/usr/lib/python2.7/locale.pyc'>
use_dbus: None
GInitiallyUnowned: <class 'gtk.__main__.GInitiallyUnowned'>
__name__: '__main__'
GPollableOutputStream: <class 'gio.__main__.GPollableOutputStream'>
GFileDescriptorBased: <class 'gio.__main__.GFileDescriptorBased'>
__doc__: None
_: <function <lambda> at 0xb7737fb4>

Potential duplicate: bug 954165
Comment 1 Fabien Archambault 2013-06-08 02:43:43 EDT
Created attachment 758477 [details]
File: backtrace
Comment 2 Fabien Archambault 2013-06-08 02:43:46 EDT
Created attachment 758478 [details]
File: environ
Comment 3 Nils Philippsen 2013-06-10 07:11:18 EDT
This is fixed in system-config-services-0.101.10-1.fc18 which is available as a stable update since mid of May. See bug #960478 for details, which covers the same issue (on Fedora 19).

Note You need to log in before you can comment on or make changes to this bug.