Bug 972309 - Error code show in ping test results page when input host length are more then 64 characters.
Error code show in ping test results page when input host length are more the...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Ryan Barry
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-08 05:39 EDT by cshao
Modified: 2014-01-21 14:41 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
An error code was displaying in the ping test results page when the input host length was more than 64 characters. This no longer occurs as there is now a check for the length of each field as well as the entire hostname to make sure it is not too long. It adds a validator for length, which checks for total length of less than 256 octets and field lengths of less than 64 octets.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:41:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ping (8.54 KB, image/png)
2013-06-08 05:39 EDT, cshao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15583 None None None Never
Red Hat Product Errata RHBA-2014:0033 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2014-01-21 19:14:30 EST

  None (edit)
Description cshao 2013-06-08 05:39:13 EDT
Created attachment 758482 [details]
ping

Description of problem:
Error code show in ping test results page when input host length are more then  64 characters.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20130528.0.el6_4
ovirt-node-2.5.0-17.el6_4.5.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H and configure network.
2. Enter network ping test page.
3. Enter a long host to ping(more then 64 characters).

Actual results:
1. Failed with error code 5 show in ping test results page when input host length are more then  64 characters.

Expected results:
Pop-up "name too long" or provide limit.

Additional info:
1. No such issue if the host length less then 64 characters.
Comment 2 Fabian Deutsch 2013-06-10 05:02:32 EDT
The FQDNOrIPAddress validator should probably be fixed to check for to long hostnames.
Comment 3 Mike Burns 2013-06-10 08:57:48 EDT
(In reply to Fabian Deutsch from comment #2)
> The FQDNOrIPAddress validator should probably be fixed to check for to long
> hostnames.

Yes, but it's 63 chars *per level*.  So we need to split on . and check each section.

test-really-really-really-really-really-long-hostname.test-really-really-really-really-really-long-hostname.example.com is perfectly fine (54 chars in the first 2 levels)
Comment 4 Ryan Barry 2013-06-11 19:09:22 EDT
This is fixed in http://gerrit.ovirt.org/#/c/15583/

It adds a validator for length which checks for total length of less than 256 octets and field lengths of less than 64 octets.
Comment 5 Ryan Barry 2013-06-11 19:09:22 EDT
This is fixed in http://gerrit.ovirt.org/#/c/15583/

It adds a validator for length which checks for total length of less than 256 octets and field lengths of less than 64 octets.
Comment 9 cshao 2013-10-24 06:20:06 EDT
rhev-hypervisor6-6.5-20131017.0
ovirt-node-3.0.1-4.el6.noarch

Test steps:
1. Install RHEV-H and configure network.
2. Enter network ping test page.
3. Enter a long host to ping(more then 64 characters).

Test result:
"The field must contain members of 63 characters or less" will pop-up.

So the bug is fixed, change bug status to VERIFIED.
Comment 11 Cheryn Tan 2013-11-07 19:26:41 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 13 errata-xmlrpc 2014-01-21 14:41:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.