Bug 972324 - yum fails to install clang, after gcc was upgraded to 4.8.1
yum fails to install clang, after gcc was upgraded to 4.8.1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-08 09:06 EDT by ahoros
Modified: 2013-08-11 07:25 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-11 07:25:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ahoros 2013-06-08 09:06:50 EDT
Description of problem:
cannot install clang via yum
after gcc upgrade to 4.1


Version-Release number of selected component (if applicable):
3.3

How reproducible:

[root@fedora19beta ~]# yum install clang
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package clang.x86_64 0:3.3-0.4.rc2.fc19 will be installed
--> Processing Dependency: llvm(x86-64) = 3.3-0.4.rc2.fc19 for package: clang-3.3-0.4.rc2.fc19.x86_64
--> Processing Dependency: libstdc++-devel = 4.8.0 for package: clang-3.3-0.4.rc2.fc19.x86_64
--> Processing Dependency: gcc = 4.8.0 for package: clang-3.3-0.4.rc2.fc19.x86_64
--> Processing Dependency: libLLVM-3.3.so()(64bit) for package: clang-3.3-0.4.rc2.fc19.x86_64
--> Running transaction check
---> Package clang.x86_64 0:3.3-0.4.rc2.fc19 will be installed
--> Processing Dependency: gcc = 4.8.0 for package: clang-3.3-0.4.rc2.fc19.x86_64
---> Package libstdc++-devel.i686 0:4.8.0-8.fc19 will be installed
--> Processing Dependency: libstdc++(x86-32) = 4.8.0-8.fc19 for package: libstdc++-devel-4.8.0-8.fc19.i686
--> Processing Dependency: libstdc++.so.6 for package: libstdc++-devel-4.8.0-8.fc19.i686
---> Package llvm.x86_64 0:3.3-0.4.rc2.fc19 will be installed
---> Package llvm-libs.x86_64 0:3.3-0.4.rc2.fc19 will be installed
--> Running transaction check
---> Package clang.x86_64 0:3.3-0.4.rc2.fc19 will be installed
--> Processing Dependency: gcc = 4.8.0 for package: clang-3.3-0.4.rc2.fc19.x86_64
---> Package libstdc++.i686 0:4.8.0-8.fc19 will be installed
--> Processing Dependency: libm.so.6(GLIBC_2.0) for package: libstdc++-4.8.0-8.fc19.i686
--> Processing Dependency: libm.so.6 for package: libstdc++-4.8.0-8.fc19.i686
--> Processing Dependency: libgcc_s.so.1(GLIBC_2.0) for package: libstdc++-4.8.0-8.fc19.i686
--> Processing Dependency: libgcc_s.so.1(GCC_4.2.0) for package: libstdc++-4.8.0-8.fc19.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.3) for package: libstdc++-4.8.0-8.fc19.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: libstdc++-4.8.0-8.fc19.i686
--> Processing Dependency: libgcc_s.so.1 for package: libstdc++-4.8.0-8.fc19.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: libstdc++-4.8.0-8.fc19.i686
--> Processing Dependency: ld-linux.so.2(GLIBC_2.3) for package: libstdc++-4.8.0-8.fc19.i686
--> Processing Dependency: ld-linux.so.2 for package: libstdc++-4.8.0-8.fc19.i686
--> Running transaction check
---> Package clang.x86_64 0:3.3-0.4.rc2.fc19 will be installed
--> Processing Dependency: gcc = 4.8.0 for package: clang-3.3-0.4.rc2.fc19.x86_64
---> Package glibc.i686 0:2.17-4.fc19 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.17-4.fc19.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.17-4.fc19.i686
---> Package libgcc.i686 0:4.8.1-1.fc19 will be installed
--> Running transaction check
---> Package clang.x86_64 0:3.3-0.4.rc2.fc19 will be installed
--> Processing Dependency: gcc = 4.8.0 for package: clang-3.3-0.4.rc2.fc19.x86_64
---> Package nss-softokn-freebl.i686 0:3.14.3-1.fc19 will be installed
--> Finished Dependency Resolution
Error: Package: clang-3.3-0.4.rc2.fc19.x86_64 (fedora)
           Requires: gcc = 4.8.0
           Installed: gcc-4.8.1-1.fc19.x86_64 (@updates-testing)
               gcc = 4.8.1-1.fc19
           Available: gcc-4.8.0-8.fc19.x86_64 (fedora)
               gcc = 4.8.0-8.fc19
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@fedora19beta ~]# 


Expected results:


seamless, automatic installation

Additional info:

Note You need to log in before you can comment on or make changes to this bug.