Bug 972341 - The libmatheval.info file is not included in the libmatheval.rpm file.
The libmatheval.info file is not included in the libmatheval.rpm file.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libmatheval (Show other bugs)
19
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-08 13:13 EDT by Peter Trenholme
Modified: 2013-06-08 16:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-08 16:05:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Trenholme 2013-06-08 13:13:13 EDT
Description of problem:
The libmatheval.info file is not included in the libmatheval.rpm file. It is in the source file.

Version-Release number of selected component (if applicable):
1.1.10

How reproducible:
Always

Steps to Reproduce:
1.Install the libmatheval.rpm package
2.Run, e.g., pinfo libmathevel
3.

Actual results:
Error: No info file found

Expected results:
Info file display

Additional info:
The manual is available on-line, so this is a relative minor problem.

But the documentation is included in the source package, so it should probably
be in the distribution rpm. 

================

Another thing to consider (also quite minor):

The RPM package installs two scripts in /bin: guile-config and guile-snarf.

The first script, guile-config, explicitly states that is "depreciated" and that
the "pkg-config" metadata file for "libmatheval is
installed along with the library. Therefor, on system with "pkg-config
installed, following command could be used to use the Scheme code generated:

     gcc <example>.c $(pkg-config --cflags --libs) -o <example>

Since Fedora always includes pkg-config, perhaps this could be simplified.
Comment 1 Peter Trenholme 2013-06-08 15:13:07 EDT
Oops! My bad! I forgot to include libmatheval-devel!

(Although the last comment seems to still be valid.)

Note You need to log in before you can comment on or make changes to this bug.