Bug 972372 - gnome-icon-theme shouldn't own /usr/share/pkgconfig
gnome-icon-theme shouldn't own /usr/share/pkgconfig
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-icon-theme (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-08 20:14 EDT by leigh scott
Modified: 2013-08-09 13:13 EDT (History)
7 users (show)

See Also:
Fixed In Version: gnome-icon-theme-3.8.3-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 16:42:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description leigh scott 2013-06-08 20:14:58 EDT
Description of problem: gnome-icon-theme shouldn't /usr/share/pkgconfig


Version-Release number of selected component (if applicable):

gnome-icon-theme-3.8.2-2.fc19




Expected results:

I expect pkgconfig to own /usr/share/pkgconfig
Comment 2 leigh scott 2013-06-11 02:25:43 EDT
(In reply to Matthias Clasen from comment #1)
> That would needlessly pull pkgconfig into every install.
> 
 
FYI any package that contains a .pc file will automatically pull pkconfig as a requirement.

https://koji.fedoraproject.org/koji/rpminfo?rpmID=4064266

you build still requires pkconfig so your change was completely senseless, if you want to get rid of the pkconfig dep you will need to split the .pc into a separate -devel sub-package. 



> See
> https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/
> Guidelines#The_directory_is_owned_by_a_package_which_is_not_required_for_your
> _package_to_function


I know the guideline :p
Comment 3 leigh scott 2013-06-11 02:37:10 EDT
Output for your new package shows pkconfig as a requirement!


$ rpm -qp --requires gnome-icon-theme-3.8.2-2.fc19.noarch.rpm 
/bin/sh
/bin/sh
/bin/sh
/usr/bin/pkg-config
hicolor-icon-theme
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
Comment 4 Dan Mashal 2013-06-11 03:42:23 EDT
This is wrong. Matthias, please follow the proper packaging guidelines.
Comment 5 Dan Mashal 2013-06-11 05:24:07 EDT
I am splitting off a devel file and fixing most of the rpmlint bugs. Will push this out shortly.
Comment 6 Fedora Update System 2013-06-11 06:51:09 EDT
gnome-icon-theme-3.8.2-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-icon-theme-3.8.2-3.fc19
Comment 7 Fedora Update System 2013-06-11 13:58:16 EDT
Package gnome-icon-theme-3.8.2-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-icon-theme-3.8.2-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-10588/gnome-icon-theme-3.8.2-3.fc19
then log in and leave karma (feedback).
Comment 8 Kevin Fenzi 2013-06-11 16:21:10 EDT
So, with this change all the packages that build with it will need to be changed to pull in the -devel subpackage? 

Do we want to try and change them all before freeze? Or just revert this in f19 for now and change it only in rawhide?
Comment 9 Kalev Lember 2013-06-12 07:23:57 EDT
It would be best to leave the package split for rawhide only. Dan, can you unpush the F19 update and revert the changes in the git f19 branch, please?

I'll fix up the GNOME stack in rawhide to buildrequire the -devel package, but it's too late for F19 at this point.

----------------------------------------

Some comments about the changes to the spec file:

1) I see you have changed BRs as follows:

gettext -> gnome-common
gtk2 -> gtk2-devel
librsvg2 -> librsvg2-devel

What's the rationale for this? It only makes the package build slower in koji if you add additional (unneeded) buildrequires.

2) In both -legacy and -devel:

> -Requires: %{name} = %{version}-%{release}
> +Requires: %{name}%{?_isa} = %{version}-%{release}

Adding %{?_isa} makes no sense because the package is noarch; it is only needed if you need to specify a dependency on a particular multilib arch.

3) 
> +%description devel
> +Development files for gnome-icon-theme

Add a full stop at the end of %description.

4) License: GPL+ -> LGPLv2+

How did you determine that it's LGPLv2+ ? The COPYING file as shipped in the tarball says
"GNOME icon theme is distributed under the terms of either GNU LGPL v.3 or Creative Commons BY-SA 3.0 license."
... and there are LGPLv3 (COPYING_LGPL) and CC-BY-SA (COPYING_CCBYSA3) license texts in the tarball.

The package guidelines also say you are required to sent an announcement to the devel list when a package license changes.
https://fedoraproject.org/wiki/Licensing:Main#License_Changes
Comment 10 Dan Mashal 2013-06-12 13:31:00 EDT
(In reply to Kalev Lember from comment #9)
> It would be best to leave the package split for rawhide only. Dan, can you
> unpush the F19 update and revert the changes in the git f19 branch, please?
> 
> I'll fix up the GNOME stack in rawhide to buildrequire the -devel package,
> but it's too late for F19 at this point.
> 
> ----------------------------------------
> 
> Some comments about the changes to the spec file:
> 
> 1) I see you have changed BRs as follows:
> 
> gettext -> gnome-common
> gtk2 -> gtk2-devel
> librsvg2 -> librsvg2-devel
> 
> What's the rationale for this? It only makes the package build slower in
> koji if you add additional (unneeded) buildrequires.
> 
> 2) In both -legacy and -devel:
> 
> > -Requires: %{name} = %{version}-%{release}
> > +Requires: %{name}%{?_isa} = %{version}-%{release}
> 
> Adding %{?_isa} makes no sense because the package is noarch; it is only
> needed if you need to specify a dependency on a particular multilib arch.
> 
> 3) 
> > +%description devel
> > +Development files for gnome-icon-theme
> 
> Add a full stop at the end of %description.
> 
> 4) License: GPL+ -> LGPLv2+
> 
> How did you determine that it's LGPLv2+ ? The COPYING file as shipped in the
> tarball says
> "GNOME icon theme is distributed under the terms of either GNU LGPL v.3 or
> Creative Commons BY-SA 3.0 license."
> ... and there are LGPLv3 (COPYING_LGPL) and CC-BY-SA (COPYING_CCBYSA3)
> license texts in the tarball.
> 
> The package guidelines also say you are required to sent an announcement to
> the devel list when a package license changes.
> https://fedoraproject.org/wiki/Licensing:Main#License_Changes

Will unpush and fix license again.
Comment 11 Fedora Update System 2013-08-06 17:23:24 EDT
gnome-icon-theme-3.8.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-icon-theme-3.8.3-1.fc19
Comment 12 Fedora Update System 2013-08-09 13:13:15 EDT
gnome-icon-theme-3.8.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.