Bug 972379 - [virtio-win][serial]cannot upgrade/downgrade the vioser driver on win2k3-32guest.
[virtio-win][serial]cannot upgrade/downgrade the vioser driver on win2k3-32gu...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Gal Hammer
Virtualization Bugs
: Regression, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-08 23:01 EDT by Min Deng
Modified: 2013-09-16 12:16 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
It is not possible to downgrade a driver using the Search for the best driver in these locations option because the newer and installed driver will be selected as the "best" driver. If you want to force installation of a particular driver version, use the "Don't search option" and the "Have Disk" button to select the folder of the older driver. This method will allow you to install an older driver on a system that already has a driver installed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 05:14:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Min Deng 2013-06-08 23:01:31 EDT
Description of problem:
Cannot upgrade driver in win2k3-32 guest.
Version-Release number of selected component (if applicable):
Build64
How reproducible:
3 times failed 3 times

Steps to Reproduce:
1.boot up guest and install vioser driver with build 64
2.go to Device Manager -> select serail driver -> right click it -> select upgrade driver,here,I choose build 59 for the target one -> "search for the best driver in these locations" -> folder->Wxp->x86 (59)
3.The driver could not be installed successfully.

Actual results:
Cannot continue the hardware Upgrade wizard pops up

Expected results:
The driver can be upgraded/downgraded

Additional info:
It should be a regression issue.
Comment 3 Gal Hammer 2013-06-09 02:41:25 EDT
(In reply to dengmin from comment #0)
> Description of problem:
> Cannot upgrade driver in win2k3-32 guest.
> Version-Release number of selected component (if applicable):
> Build64
> How reproducible:
> 3 times failed 3 times
> 
> Steps to Reproduce:
> 1.boot up guest and install vioser driver with build 64
> 2.go to Device Manager -> select serail driver -> right click it -> select
> upgrade driver,here,I choose build 59 for the target one -> "search for the
> best driver in these locations" -> folder->Wxp->x86 (59)

It probably not the problem, but the Wxp->x86 is not the right folder for Windows 2003. You should use the wnet folder.

> 3.The driver could not be installed successfully.

I think that's the expected behavior, no? Windows should tell you that you have a newer driver already installed.
 
> Actual results:
> Cannot continue the hardware Upgrade wizard pops up
> 
> Expected results:
> The driver can be upgraded/downgraded
> 
> Additional info:
> It should be a regression issue.
Comment 5 Min Deng 2013-06-12 22:12:49 EDT
(In reply to Gal Hammer from comment #3)
> (In reply to dengmin from comment #0)
> > Description of problem:
> > Cannot upgrade driver in win2k3-32 guest.
> > Version-Release number of selected component (if applicable):
> > Build64
> > How reproducible:
> > 3 times failed 3 times
> > 
> > Steps to Reproduce:
> > 1.boot up guest and install vioser driver with build 64
> > 2.go to Device Manager -> select serail driver -> right click it -> select
> > upgrade driver,here,I choose build 59 for the target one -> "search for the
> > best driver in these locations" -> folder->Wxp->x86 (59)
> 
> It probably not the problem, but the Wxp->x86 is not the right folder for
> Windows 2003. You should use the wnet folder.
  Hi Gal,
     I don't think I install driver from wrong folder and please have a look on the following mapping tables.
     https://docspace.corp.redhat.com/docs/DOC-97715 
> > 3.The driver could not be installed successfully.
> 
> I think that's the expected behavior, no? Windows should tell you that you
> have a newer driver already installed.
  I know what's your mean but I really do not see such a dialog at this time.Any issues please let me know.
>  
> > Actual results:
> > Cannot continue the hardware Upgrade wizard pops up
> > 
> > Expected results:
> > The driver can be upgraded/downgraded
> > 
> > Additional info:
> > It should be a regression issue.
Comment 6 Ronen Hod 2013-07-23 09:59:06 EDT
We would like to close this bug
- A workaround for downgrade should be to uninstall first
- We try to avoid non-urgent 2003 work
Any objection?
Is it really a regression?
Comment 7 Mike Cao 2013-07-23 22:24:05 EDT
(In reply to Ronen Hod from comment #6)
> We would like to close this bug
> - A workaround for downgrade should be to uninstall first
> - We try to avoid non-urgent 2003 work
> Any objection?
> Is it really a regression?

May not .
Deng Min, Pls try to upgrade driver via following ways :
2.go to Device Manager -> select serail driver -> right click it -> select upgrade driver,here,I choose build 59 for the target one -> "No not search ,I will install the driver manually ---> have disks -> folder->Wxp->x86 (59)
Comment 8 Min Deng 2013-07-24 03:46:43 EDT
(In reply to Mike Cao from comment #7)
> (In reply to Ronen Hod from comment #6)
> > We would like to close this bug
> > - A workaround for downgrade should be to uninstall first
> > - We try to avoid non-urgent 2003 work
> > Any objection?
> > Is it really a regression?
> 
> May not .
> Deng Min, Pls try to upgrade driver via following ways :
> 2.go to Device Manager -> select serail driver -> right click it -> select
> upgrade driver,here,I choose build 59 for the target one -> "No not search
> ,I will install the driver manually ---> have disks -> folder->Wxp->x86 (59)

Hi All,
   If I did this "Not search and install driver manually -> folder -> Wxp -> x86",it worked well.
   Besides,I could get the same error to comments0 where using "search for the best driver in these locations"...
   Anyway,the search option doesn't work properly for this driver in my opinion,it should be a shortcoming while user want to install driver by this way.
   Any issues please let me know.Thanks.

Best Regards,
Min
Comment 9 Gal Hammer 2013-07-25 10:03:04 EDT
The "Search for the best driver in these locations" should not be used to search for a driver under a directory tree that contains drivers for multiple OSes (the tree layout that we're using).
Comment 10 Min Deng 2013-07-25 23:38:23 EDT
(In reply to Gal Hammer from comment #9)
> The "Search for the best driver in these locations" should not be used to
> search for a driver under a directory tree that contains drivers for
> multiple OSes (the tree layout that we're using).

Hi Gal,

   Could you please double check the issue before close it as Not a bug ? 
I described as the following on the original info,
"search for the best driver in these locations" -> folder->Wxp->x86 (59).The driver is under folder "x86" directly but not contains a directory tree.
   Any issues please let me know.

Thanks
Min
Comment 11 Gal Hammer 2013-08-08 04:59:42 EDT
(In reply to dengmin from comment #10)
> (In reply to Gal Hammer from comment #9)
> > The "Search for the best driver in these locations" should not be used to
> > search for a driver under a directory tree that contains drivers for
> > multiple OSes (the tree layout that we're using).
> 
> Hi Gal,
> 
>    Could you please double check the issue before close it as Not a bug ? 
> I described as the following on the original info,
> "search for the best driver in these locations" -> folder->Wxp->x86 (59).The
> driver is under folder "x86" directly but not contains a directory tree.
>    Any issues please let me know.

My mistake, sorry.
 
> Thanks
> Min

It seem that you can't downgrade a driver using the "Search for the best driver in these locations" option because the newer (and installed) driver will be selected the as "best" driver.

So if want to force installation of a you should use the "Don't search" option and the "Have Disk" button to select the folder of the older driver. This method will allow you to install an older driver on a system that already have a driver installed.

Note You need to log in before you can comment on or make changes to this bug.