Bug 972472 - yum can not update or install any new software
yum can not update or install any new software
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-09 12:21 EDT by bunnyman2000
Modified: 2014-06-25 02:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-25 02:05:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bunnyman2000 2013-06-09 12:21:24 EDT
Description of problem:Unable to install or update software using Yum or Software Update tool.


Version-Release number of selected component (if applicable): Redhat 6.3


How reproducible:Run 'yum update' or try to install any package with 'yum install'


Steps to Reproduce:
1.yum update
2.
3.

Actual results:A window pops up saying "An Internal System Error Has Occured" with the following report:

Error Type: <class 'up2date_client.up2dateErrors.NetworkError'>
Error Value: Network error: 
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3278, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3274, in main
    backend = PackageKitYumBackend('', lock=True)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 238, in __init__
    self.doLock()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 321, in doLock
    self.yumbase.doLock(YUM_PID_FILE)
  File : /usr/lib/python2.6/site-packages/yum/__init__.py, line 1777, in doLock
    if self.conf.uid != 0:
  File : /usr/lib/python2.6/site-packages/yum/__init__.py, line 901, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File : /usr/lib/python2.6/site-packages/yum/__init__.py, line 358, in _getConfig
    self.plugins.run('init')
  File : /usr/lib/python2.6/site-packages/yum/plugins.py, line 184, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File : /usr/share/yum-plugins/rhnplugin.py, line 114, in init_hook
    login_info = up2dateAuth.getLoginInfo()
  File : /usr/share/rhn/up2date_client/up2dateAuth.py, line 219, in getLoginInfo
    login()
  File : /usr/share/rhn/up2date_client/up2dateAuth.py, line 186, in login
    li = server.up2date.login(systemId)
  File : /usr/share/rhn/up2date_client/rhnserver.py, line 51, in __call__
    return rpcServer.doCall(method, *args, **kwargs)
  File : /usr/share/rhn/up2date_client/rpcServer.py, line 206, in doCall
    ret = method(*args, **kwargs)
  File : /usr/lib/python2.6/xmlrpclib.py, line 1199, in __call__
    return self.__send(self.__name, args)
  File : /usr/share/rhn/up2date_client/rpcServer.py, line 39, in _request1
    ret = self._request(methodname, params)
  File : /usr/lib/python2.6/site-packages/rhn/rpclib.py, line 383, in _request
    self._handler, request, verbose=self._verbose)
  File : /usr/lib/python2.6/site-packages/rhn/transports.py, line 171, in request
    headers, fd = req.send_http(host, handler)
  File : /usr/lib/python2.6/site-packages/rhn/transports.py, line 702, in send_http
    self._connection.connect()
  File : /usr/lib/python2.6/site-packages/rhn/connections.py, line 222, in connect
    self.sock.init_ssl()
  File : /usr/lib/python2.6/site-packages/rhn/SSL.py, line 76, in init_ssl
    self._ctx.load_verify_locations(f)


Expected results: Yum should have updated the installed packages or installed new packages.


Additional info: I have no problem getting to the internet through this server.  This is a virtual server that is accessed and created by Oracle VM VirtualBox
Comment 1 Zdeněk Pavlas 2013-06-10 03:08:59 EDT
Looks like a certificate problem.. is the system time set properly?
Comment 3 Michael Mráka 2013-06-10 04:30:09 EDT
Does yum work if you disable rhnplugin?
Does the server have correct SSL certificate specified in /etc/sysconfig/rhn/up2date?
What's the output of rhn_check -vv?
Comment 4 RHEL Product and Program Management 2013-10-13 23:23:21 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 bunnyman2000 2014-06-24 10:54:28 EDT
Please close this ticket.
Comment 6 Michael Mráka 2014-06-25 02:05:29 EDT
Closing on reporters request (comment #5).

Note You need to log in before you can comment on or make changes to this bug.