Bug 972501 - cannot default to have no menu
cannot default to have no menu
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-terminal (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-09 14:49 EDT by Barry Fishman
Modified: 2014-12-20 11:00 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-20 11:00:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry Fishman 2013-06-09 14:49:48 EDT
Description of problem:

Previous version of gnome-terminal would remember that you selected not to
show the menubar.  Now even if you shut off the menu and then right clicked
to open a new terminal, the new window will have the menu displayed.

This is even true if the gnome-shell is initially stared with a
"--hide-menubar" option.  Although the initial window will not have a menubar
the subsequently launched windows do.

Version-Release number of selected component (if applicable):

gnome-terminal.x86_64 3.9.2-1.fc19

How reproducible:

Always
Steps to Reproduce:

Worst case:
1. Launch gnome-terminal --hide-menubar
2. Right click on the window and select Open Terminal

Actual results:

The new window will have a menubar

Expected results

The new window would not have a menubar.  In previous versions you could
select for gnome-terminal to never show a menubar unless you reselected it.

Additional info:
Comment 1 Steve 2013-07-03 09:27:46 EDT
I can confirm this behaviour as well.  As a temporary fix, one can go into dconf-editor and then under org.gnome.terminal.legacy, uncheck the "default-show-menubar" value.
Comment 2 Jan Kristian 2013-10-18 09:08:45 EDT
This bug bugs me too, but thankfully the workaround mentioned by Steve worked great!
Comment 3 Isaac Lenton 2013-11-02 10:49:16 EDT
Wouldn't it be more convenient if the menubar option is stored in the terminal profiles.  A entry in the profile preferences could then be added rather then messing around with dconf-editor.
Comment 4 Pete Zaitcev 2013-11-04 14:36:22 EST
The checkbox was there, but they removed it.
Comment 5 Pete Zaitcev 2013-11-04 14:43:07 EST
Or, actually, here's how it works... They split off a few preferences away
from the profile preferences. So now you have what's in profile, and
the "Preferences". That includes a checkbox "Show menubar by default in
new terminals". It works just fine. HOWEVER, the problem is, Preferences
are only linked off the Edit menu, which is not available if menubar is
not visible.

So, the workaround is:
 - Open terminal
 - Show menubar (don't worry, it only happens in this vindow)
 - Edit->Preferences->General, uncheck "Show menubars by default"
 - Close
 - Uncheck "Show menubar"

Same effect as Steve's workaround.
Comment 6 Barry Fishman 2013-11-04 18:11:27 EST
Re Comment #5:  At the time I though I looked in all the sub-menus, but clearly
it is there now.  Why there is a distinction made between "Preferences" and
"Profile Preferences" is beyond me.  Thanks.
Comment 7 Egmont Koblinger 2014-08-13 19:36:39 EDT
(In reply to Barry Fishman from comment #6)
> Why there is a distinction made between "Preferences" and
> "Profile Preferences" is beyond me.

Profile Preferences is for things that belong to profiles, Preferences is for things that don't.  You may have multiple gnome-terminal tabs, each with a different profile (i.e. different colors, font, encoding etc.).  It would be a terrible user experience if the menu appeared/disappeared when changing tabs (especially since the menubar is above the tab bar), that's why it's not a profile preference.  I hope this makes sense.
Comment 8 Barry Fishman 2014-08-14 08:47:17 EDT
(In reply to Egmont Koblinger from comment #7)
> ... It would
> be a terrible user experience if the menu appeared/disappeared when changing
> tabs (especially since the menubar is above the tab bar), that's why it's
> not a profile preference.  I hope this makes sense.

Not really.  First the terminology is bad.  Then the idea that the existance of menubars is independent of a profile (which are really application defaults) is illogical.  Seperating out menubars mean that the state of menubars you last selected is either ignored on the next launch of the application or used irrespective of any profile selected.

I can see having multiple profiles and having a specific profile selected to be used the next time the application starts.  But I don't see why menubars are particularly special.

The fact that you now tell me that these settings can change between tabs, I find even more unsettling. :-(
Comment 9 Egmont Koblinger 2014-08-14 09:18:11 EDT
(In reply to Barry Fishman from comment #8)

> First the terminology is bad.

Which terminology?  And why?

> Then the idea that the existance
> of menubars is independent of a profile (which are really application
> defaults) is illogical.

Why is it illogical?

What makes you think profiles are application defaults?  They are not.  I have a feeling you don't get the idea what profiles are for.

> The fact that you now tell me that these settings can change between tabs, I
> find even more unsettling. :-(

Wow, did it surprise you that if you have two tabs with different profiles then the profiles change when you switch tabs?  If so then you really don't get what profiles are. ;)

What is your use case?  How do you use gnome-terminal?  Do you use profiles, if so then how?  Do you keep changing the menubar visibility?  If yes, when and why?  Do you keep changing the default visibility of the menubar (for new windows)?  If yes, again: why?

I would think that the menubar is something that a user either wants to see all the time, or never.  Configure once and live on with that setting.  I'd be curious to understand the reasons if it's not the case for you.
Comment 10 Barry Fishman 2014-08-14 09:52:11 EDT
(In reply to Egmont Koblinger from comment #9)

I should have just stated that the bug has been resolved, and this is not the place for a discussion of interface decisions.
Comment 11 Pete Zaitcev 2014-12-20 11:00:26 EST
Marking as closed per original requestor's comment #10.

Also, verified in
gnome-terminal-3.14.2-1.fc21.x86_64
vte3-0.36.3-3.fc21.x86_64

Note You need to log in before you can comment on or make changes to this bug.