Bug 972502 - SELinux is preventing /usr/bin/wineserver from 'lock' accesses on the file /home/user9/.wine/drive_c/users/user9/Application Data/wine_gecko/places.sqlite-shm.
SELinux is preventing /usr/bin/wineserver from 'lock' accesses on the file /h...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:9b85e980c9c23711f4489965247...
:
: 972503 972504 972505 972506 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-09 15:02 EDT by Moez Roy
Modified: 2013-07-24 20:39 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.11.1-98.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 20:39:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-09 15:02:07 EDT
Description of problem:
SELinux is preventing /usr/bin/wineserver from 'lock' accesses on the file /home/user9/.wine/drive_c/users/user9/Application Data/wine_gecko/places.sqlite-shm.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that wineserver should be allowed lock access on the places.sqlite-shm file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep wineserver /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:wine_home_t:s0
Target Objects                /home/user9/.wine/drive_c/users/user9/Application
                              Data/wine_gecko/places.sqlite-shm [ file ]
Source                        wineserver
Source Path                   /usr/bin/wineserver
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   35
First Seen                    2013-06-07 00:43:46 PDT
Last Seen                     2013-06-09 11:03:01 PDT
Local ID                      95214735-cd24-4621-b449-26906408d429

Raw Audit Messages
type=AVC msg=audit(1370800981.566:2471): avc:  denied  { lock } for  pid=17158 comm="wineserver" path=2F686F6D652F75736572392F2E77696E652F64726976655F632F75736572732F75736572392F4170706C69636174696F6E20446174612F77696E655F6765636B6F2F706C616365732E73716C6974652D73686D dev="dm-3" ino=46137936 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:wine_home_t:s0 tclass=file


type=SYSCALL msg=audit(1370800981.566:2471): arch=x86_64 syscall=fcntl success=yes exit=0 a0=d8 a1=6 a2=7ffff79b43a0 a3=0 items=0 ppid=1 pid=17158 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=2 tty=(none) comm=wineserver exe=2F7573722F62696E2F77696E65736572766572202864656C6574656429 subj=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 key=(null)

Hash: wineserver,wine_t,wine_home_t,file,lock

audit2allow

#============= wine_t ==============
allow wine_t wine_home_t:file lock;

audit2allow -R
require {
	type wine_t;
	type wine_home_t;
	class file lock;
}

#============= wine_t ==============
allow wine_t wine_home_t:file lock;


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-11 09:15:45 EDT
*** Bug 972503 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2013-06-11 09:15:53 EDT
*** Bug 972504 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2013-06-11 09:16:12 EDT
*** Bug 972506 has been marked as a duplicate of this bug. ***
Comment 4 Miroslav Grepl 2013-06-11 09:19:13 EDT
commit abccff6db4d9341d0374c37267af60a2ec21fa24
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Tue Jun 11 15:18:22 2013 +0200

    Allow wine to manage wine home content
Comment 5 Miroslav Grepl 2013-06-11 09:19:28 EDT
*** Bug 972505 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2013-06-27 09:35:35 EDT
selinux-policy-3.11.1-98.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-98.fc18
Comment 7 Fedora Update System 2013-06-28 02:09:38 EDT
Package selinux-policy-3.11.1-98.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-98.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11859/selinux-policy-3.11.1-98.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-07-24 20:39:30 EDT
selinux-policy-3.11.1-98.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.