Bug 972506 - SELinux is preventing /usr/bin/wine-preloader from 'rmdir' accesses on the directory Download.
SELinux is preventing /usr/bin/wine-preloader from 'rmdir' accesses on the di...
Status: CLOSED DUPLICATE of bug 972502
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f1bd608f0b9268ba49fbd574e00...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-09 15:05 EDT by Moez Roy
Modified: 2013-06-11 09:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 09:16:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-06-09 15:05:49 EDT
Description of problem:
SELinux is preventing /usr/bin/wine-preloader from 'rmdir' accesses on the directory Download.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that wine-preloader should be allowed rmdir access on the Download directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep GoogleUpdate.ex /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:wine_home_t:s0
Target Objects                Download [ dir ]
Source                        GoogleUpdate.ex
Source Path                   /usr/bin/wine-preloader
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           wine-core-1.5.29-1.fc18.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.4-200.fc18.x86_64 #1 SMP Fri
                              May 24 20:10:49 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-06-07 01:17:49 PDT
Last Seen                     2013-06-07 01:17:49 PDT
Local ID                      85d42cad-924b-442b-896a-c1635ee41623

Raw Audit Messages
type=AVC msg=audit(1370593069.688:1718): avc:  denied  { rmdir } for  pid=22321 comm="GoogleUpdate.ex" name="Download" dev="dm-3" ino=46138379 scontext=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:wine_home_t:s0 tclass=dir


type=SYSCALL msg=audit(1370593069.688:1718): arch=i386 syscall=sendfile success=yes exit=0 a0=136328 a1=33f490 a2=7b8b6000 a3=33f4d0 items=0 ppid=1 pid=22321 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=2 tty=(none) comm=GoogleUpdate.ex exe=/usr/bin/wine-preloader subj=unconfined_u:unconfined_r:wine_t:s0-s0:c0.c1023 key=(null)

Hash: GoogleUpdate.ex,wine_t,wine_home_t,dir,rmdir

audit2allow

#============= wine_t ==============
allow wine_t wine_home_t:dir rmdir;

audit2allow -R
require {
	type wine_t;
	type wine_home_t;
	class dir rmdir;
}

#============= wine_t ==============
allow wine_t wine_home_t:dir rmdir;


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.4-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-11 09:16:12 EDT

*** This bug has been marked as a duplicate of bug 972502 ***

Note You need to log in before you can comment on or make changes to this bug.