Bug 972515 - [abrt] evolution-3.8.2-1.fc19: WTF::fastMalloc: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-3.8.2-1.fc19: WTF::fastMalloc: Process /usr/bin/evolution wa...
Status: CLOSED DUPLICATE of bug 967340
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:25c09575ff930d2bf1425b5eec9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-09 15:55 EDT by James Heather
Modified: 2013-06-11 02:14 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 02:14:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (110.17 KB, text/plain)
2013-06-09 15:55 EDT, James Heather
no flags Details
File: cgroup (140 bytes, text/plain)
2013-06-09 15:55 EDT, James Heather
no flags Details
File: core_backtrace (8.29 KB, text/plain)
2013-06-09 15:55 EDT, James Heather
no flags Details
File: dso_list (49.28 KB, text/plain)
2013-06-09 15:55 EDT, James Heather
no flags Details
File: environ (1.76 KB, text/plain)
2013-06-09 15:55 EDT, James Heather
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-09 15:55 EDT, James Heather
no flags Details
File: maps (221.49 KB, text/plain)
2013-06-09 15:55 EDT, James Heather
no flags Details
File: open_fds (1.53 KB, text/plain)
2013-06-09 15:55 EDT, James Heather
no flags Details
File: proc_pid_status (936 bytes, text/plain)
2013-06-09 15:55 EDT, James Heather
no flags Details
File: var_log_messages (905 bytes, text/plain)
2013-06-09 15:55 EDT, James Heather
no flags Details
File: xsession_errors (4.22 KB, text/plain)
2013-06-09 15:55 EDT, James Heather
no flags Details

  None (edit)
Description James Heather 2013-06-09 15:55:14 EDT
Description of problem:
Just started evolution.

Version-Release number of selected component:
evolution-3.8.2-1.fc19

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        evolution
crash_function: WTF::fastMalloc
executable:     /usr/bin/evolution
kernel:         3.9.4-300.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 WTF::fastMalloc at /lib64/libjavascriptcoregtk-3.0.so.0
 #1 WTF::StringImpl::createUninitialized at /lib64/libjavascriptcoregtk-3.0.so.0
 #2 WTF::StringImpl::create at /lib64/libjavascriptcoregtk-3.0.so.0
 #4 WTF::String::String at /lib64/libjavascriptcoregtk-3.0.so.0
 #5 WebCore::PluginPackage::fetchInfo at /lib64/libwebkitgtk-3.0.so.0
 #6 WebCore::PluginPackage::createPackage at /lib64/libwebkitgtk-3.0.so.0
 #7 WebCore::PluginDatabase::refresh at /lib64/libwebkitgtk-3.0.so.0
 #8 WebCore::PluginDatabase::installedPlugins at /lib64/libwebkitgtk-3.0.so.0
 #9 webkit_web_plugin_database_init at /lib64/libwebkitgtk-3.0.so.0
 #10 g_type_create_instance at gtype.c:1917
Comment 1 James Heather 2013-06-09 15:55:18 EDT
Created attachment 758912 [details]
File: backtrace
Comment 2 James Heather 2013-06-09 15:55:21 EDT
Created attachment 758913 [details]
File: cgroup
Comment 3 James Heather 2013-06-09 15:55:24 EDT
Created attachment 758914 [details]
File: core_backtrace
Comment 4 James Heather 2013-06-09 15:55:27 EDT
Created attachment 758915 [details]
File: dso_list
Comment 5 James Heather 2013-06-09 15:55:30 EDT
Created attachment 758916 [details]
File: environ
Comment 6 James Heather 2013-06-09 15:55:35 EDT
Created attachment 758917 [details]
File: limits
Comment 7 James Heather 2013-06-09 15:55:40 EDT
Created attachment 758918 [details]
File: maps
Comment 8 James Heather 2013-06-09 15:55:43 EDT
Created attachment 758919 [details]
File: open_fds
Comment 9 James Heather 2013-06-09 15:55:46 EDT
Created attachment 758920 [details]
File: proc_pid_status
Comment 10 James Heather 2013-06-09 15:55:48 EDT
Created attachment 758921 [details]
File: var_log_messages
Comment 11 James Heather 2013-06-09 15:55:51 EDT
Created attachment 758922 [details]
File: xsession_errors
Comment 12 Milan Crha 2013-06-10 05:21:48 EDT
Thanks for a bug report. I suppose this is bug #967340. If you've installed, please uninstall google-talkplugin, which is causing this crash (according to bug #967340). Please let me know whether it was it, thus I'll know whether I can close this as a duplicate of the mentioned bug report. Thanks in advance.
Comment 13 James Heather 2013-06-10 07:44:42 EDT
That does seem to have solved it, yes. Thank you.

I've noticed that it works with kernel-3.9.4-300.fc19.x86_64 even when google-talkplugin is installed. The problem comes when I boot into kernel-3.9.4-301.fc19.x86_64 with google-talkplugin installed.
Comment 14 Milan Crha 2013-06-11 02:14:01 EDT
Thanks for the update. It's suprising to me that this depends on kernel version, I thought that the google-talkplugin uses gtk2, while evolution uses gtk3, and these two cannot run together in one application, but maybe I misread the plugin's documentation.

*** This bug has been marked as a duplicate of bug 967340 ***

Note You need to log in before you can comment on or make changes to this bug.