This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 972518 - radeon_uvd: Can't load firmware "radeon/SUMO_uvd.bin"
radeon_uvd: Can't load firmware "radeon/SUMO_uvd.bin"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-09 16:01 EDT by Henry Kroll
Modified: 2013-09-16 08:42 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 08:42:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (73.52 KB, text/plain)
2013-06-09 16:01 EDT, Henry Kroll
no flags Details

  None (edit)
Description Henry Kroll 2013-06-09 16:01:47 EDT
Created attachment 758924 [details]
dmesg

Description of problem:
Dmesg reports
[    5.429405] [drm] initializing kernel modesetting (SUMO 0x1002:0x9641 0x144D:0xC608).
[    5.438220] radeon 0000:00:01.0: radeon_uvd: Can't load firmware "radeon/SUMO_uvd.bin"

Version-Release number of selected component (if applicable):
uname -r
3.10.0-0.rc2.git3.1.fc20.x86_64

How reproducible:
reboot

Steps to Reproduce:
1. boot PC
2. grep SUMO dmesg
3.

Actual results:

Error loading radeon/SUMO_uvd.bin even though the correct file
is available in /lib/firmware/radeon. Perhaps "assign_firmware_buf" has no buffer available? (buf->size=0). I am attaching dmesg. I am not sure whether the video card supports UVD functionality. This is a Samsung laptop NP-305V5A.

Expected results:


Additional info:

This could be caused by a configuration error in Fedora kernel distribution.
> 
> You compile the radeon module directly into the kernel, but don't include the
> RV710_uvd.bin firmware into your kernel image. See CONFIG_EXTRA_FIRMWARE in
> your kernel configuration for details.
> 
> Regards,
> Christian.
ref: http://www.spinics.net/lists/dri-devel/msg38844.html
Comment 1 nlazic 2013-07-01 17:31:18 EDT
Locate your .config file for kernel.
Search for CONFIG_EXTRA_FIRMWARE
add radeon/SUMO_uvd.bin to that string.
Compile kernel.
Comment 2 Vlad 2013-07-23 14:39:56 EDT
The problem is uvd firmwares are missing in initrd images. Currently dracut doesn't put those files inside of the image it creates. The problem could be solved by putting necessary file manually. For example with this command:
dracut --install /usr/lib/firmware/radeon/SUMO_uvd.bin --force

After doing so and rebooting there is a such string in dmesg: 
[drm] UVD initialized successfully.

Should we create corresponding bug for dracut?
Comment 3 Dario Di Nucci 2013-07-27 04:38:20 EDT
I've just updated F19 and now I've the new kernel 3.10.3-300.fc19.x86_64.

Under the folder /lib/firmware/radeon/ I haven't SUMO_uvd.bin and so I've the message:
Can't load firmware "radeon/SUMO_uvd.bin"

Can I do something or just wait linux-firmware to be updated?

I tried "dracut --install /usr/lib/firmware/radeon/SUMO_uvd.bin --force" but of course I've got an error since I don't have that file.
Comment 4 Dario Di Nucci 2013-07-27 07:20:46 EDT
On my machine after installing linux-firmware-20130724-28.git31f6b30.fc19 (now in testing),

dracut --install /usr/lib/firmware/radeon/SUMO_uvd.bin --force

works, without changing anything else.
Comment 5 John 2013-08-02 08:53:31 EDT
Vanilla F19 install with open display drivers.

I'm getting level 3 notification in journalctl:

kernel: radeon 0000:01:00.0: radeon_uvd: Can't load firmware "radeon/CYPRESS_uvd.bin"

lspci =   01:00.0 VGA compatible controller: Advanced Micro Devices,Inc.         [AMD/ATI] Juniper XT [Radeon HD 6770]

kernel = 3.10.3-300.fc19.x86_64
linux firmware = 20130724-28.git31f6b30.fc19

Issue resolved with:

dracut --install /usr/lib/firmware/radeon/SUMO_uvd.bin --force
Comment 6 巫书轶 2013-08-26 23:31:35 EDT
The error:
kernel: radeon 0000:01:00.0: radeon_uvd: Can't load firmware "radeon/CYPRESS_uvd.bin"
Because kernel 3.10+ add UVD video decoding
so device is need SUMO_uvd.bin, but fedora default linux-firmware not have SUMO_uvd.bin

if you update kernel 3.10+ you must update linux-firmware-20130724+
and
# dracut --install /usr/lib/firmware/radeon/SUMO_uvd.bin --force

this is fedora bug.
I hope the next version can fix.
kernel 3.10+ need linux-firmware-20130724+
and # dracut --install /usr/lib/firmware/radeon/SUMO_uvd.bin --force
Comment 7 Josh Boyer 2013-08-27 09:38:56 EDT
(In reply to 巫书轶 from comment #6)
> The error:
> kernel: radeon 0000:01:00.0: radeon_uvd: Can't load firmware
> "radeon/CYPRESS_uvd.bin"
> Because kernel 3.10+ add UVD video decoding
> so device is need SUMO_uvd.bin, but fedora default linux-firmware not have
> SUMO_uvd.bin
> 
> if you update kernel 3.10+ you must update linux-firmware-20130724+
> and
> # dracut --install /usr/lib/firmware/radeon/SUMO_uvd.bin --force
> 
> this is fedora bug.
> I hope the next version can fix.
> kernel 3.10+ need linux-firmware-20130724+
> and # dracut --install /usr/lib/firmware/radeon/SUMO_uvd.bin --force

Are you suggesting that the kernel RPM needs to bump the RPM Requires on linux-firmware?  We might be able to do that.

Otherwise, I'm not sure what you think the bug is.  All releases have linux-firmware-20130724 in stable updates.
Comment 8 巫书轶 2013-08-29 01:08:31 EDT
(In reply to Josh Boyer from comment #7)
> (In reply to 巫书轶 from comment #6)
> > The error:
> > kernel: radeon 0000:01:00.0: radeon_uvd: Can't load firmware
> > "radeon/CYPRESS_uvd.bin"
> > Because kernel 3.10+ add UVD video decoding
> > so device is need SUMO_uvd.bin, but fedora default linux-firmware not have
> > SUMO_uvd.bin
> > 
> > if you update kernel 3.10+ you must update linux-firmware-20130724+
> > and
> > # dracut --install /usr/lib/firmware/radeon/SUMO_uvd.bin --force
> > 
> > this is fedora bug.
> > I hope the next version can fix.
> > kernel 3.10+ need linux-firmware-20130724+
> > and # dracut --install /usr/lib/firmware/radeon/SUMO_uvd.bin --force
> 
> Are you suggesting that the kernel RPM needs to bump the RPM Requires on
> linux-firmware?  We might be able to do that.
> 
> Otherwise, I'm not sure what you think the bug is.  All releases have
> linux-firmware-20130724 in stable updates.

Because kernel 3.10+ add UVD video decoding,AMD UVD is need SUMO_uvd.bin
so if kernel 3.10+ need linux-firmware-20130724+
Comment 9 Josh Boyer 2013-09-04 12:02:46 EDT
OK.  I've updated the Requires in f20 and master to the newer firmware.  It should now require the newer linux-firmware packages for 3.10/3.11 kernels.

Note You need to log in before you can comment on or make changes to this bug.