Bug 972527 - AttributeError: 'NoneType' object has no attribute 'get_selected'
AttributeError: 'NoneType' object has no attribute 'get_selected'
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
abrt_hash:540124c89e68a3919cef3dd030a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-09 17:17 EDT by Petr Machata
Modified: 2015-05-04 21:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-11 12:02:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (759.68 KB, text/plain)
2013-06-09 17:17 EDT, Petr Machata
no flags Details
File: anaconda.log (9.61 KB, text/plain)
2013-06-09 17:17 EDT, Petr Machata
no flags Details
File: backtrace (267 bytes, text/plain)
2013-06-09 17:17 EDT, Petr Machata
no flags Details
File: environ (777 bytes, text/plain)
2013-06-09 17:17 EDT, Petr Machata
no flags Details
File: ifcfg.log (1.47 KB, text/plain)
2013-06-09 17:17 EDT, Petr Machata
no flags Details
File: lsblk_output (1.33 KB, text/plain)
2013-06-09 17:17 EDT, Petr Machata
no flags Details
File: nmcli_dev_list (7.22 KB, text/plain)
2013-06-09 17:17 EDT, Petr Machata
no flags Details
File: packaging.log (385.30 KB, text/plain)
2013-06-09 17:17 EDT, Petr Machata
no flags Details
File: program.log (61.03 KB, text/plain)
2013-06-09 17:17 EDT, Petr Machata
no flags Details
File: storage.log (77.31 KB, text/plain)
2013-06-09 17:17 EDT, Petr Machata
no flags Details
File: syslog (111.91 KB, text/plain)
2013-06-09 17:17 EDT, Petr Machata
no flags Details

  None (edit)
Description Petr Machata 2013-06-09 17:17:09 EDT
Description of problem:
I clicked on "make this disk bootable" button twice in short succession.  This was my laptop's sole disk.
The following was filed automatically by anaconda:
anaconda 19.28-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/cart.py", line 196, in on_set_as_boot_clicked
    model, itr = self._selection.get_selected()
AttributeError: 'NoneType' object has no attribute 'get_selected'

Version-Release number of selected component:
anaconda-19.28-1

Additional info:
reporter:       libreport-2.1.4
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=RHEL\x20Workstation\x207.0 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-0.55.el7.x86_64
product:        Red Hat Enterprise Linux
release:        Red Hat Enterprise Linux Client release 7.0 Beta (Maipo)
type:           anaconda
version:        7.0

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/cart.py", line 196, in on_set_as_boot_clicked
    model, itr = self._selection.get_selected()
AttributeError: 'NoneType' object has no attribute 'get_selected'
Comment 1 Petr Machata 2013-06-09 17:17:17 EDT
Created attachment 758943 [details]
File: anaconda-tb
Comment 2 Petr Machata 2013-06-09 17:17:20 EDT
Created attachment 758944 [details]
File: anaconda.log
Comment 3 Petr Machata 2013-06-09 17:17:23 EDT
Created attachment 758945 [details]
File: backtrace
Comment 4 Petr Machata 2013-06-09 17:17:26 EDT
Created attachment 758946 [details]
File: environ
Comment 5 Petr Machata 2013-06-09 17:17:30 EDT
Created attachment 758947 [details]
File: ifcfg.log
Comment 6 Petr Machata 2013-06-09 17:17:33 EDT
Created attachment 758948 [details]
File: lsblk_output
Comment 7 Petr Machata 2013-06-09 17:17:36 EDT
Created attachment 758949 [details]
File: nmcli_dev_list
Comment 8 Petr Machata 2013-06-09 17:17:41 EDT
Created attachment 758950 [details]
File: packaging.log
Comment 9 Petr Machata 2013-06-09 17:17:44 EDT
Created attachment 758951 [details]
File: program.log
Comment 10 Petr Machata 2013-06-09 17:17:48 EDT
Created attachment 758952 [details]
File: storage.log
Comment 11 Petr Machata 2013-06-09 17:17:52 EDT
Created attachment 758953 [details]
File: syslog
Comment 13 David Cantrell 2013-12-11 12:02:49 EST
Unable to reproduce this problem in RHEL 7.0 beta.

Note You need to log in before you can comment on or make changes to this bug.