Bug 972571 - PackageKit.x86_64 conflicts with PackageKit.i686
PackageKit.x86_64 conflicts with PackageKit.i686
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 02:31 EDT by Michael Schwendt
Modified: 2013-12-15 08:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 08:06:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2013-06-10 02:31:20 EDT
Forwarded from a Fedoraforum.de post about F18. Indeed, PackageKit.i686 is available in the x86_64 repo, and if it's ever pulled in, it currently conflicts:

Transaction check error:
  file /usr/lib/python2.7/site-packages/packagekit/__init__.pyc from install of PackageKit-0.8.9-1.fc19.i686 conflicts with file from package PackageKit-0.8.9-1.fc19.x86_64
  file /usr/lib/python2.7/site-packages/packagekit/__init__.pyo from install of PackageKit-0.8.9-1.fc19.i686 conflicts with file from package PackageKit-0.8.9-1.fc19.x86_64
  file /usr/lib/python2.7/site-packages/packagekit/backend.pyc from install of PackageKit-0.8.9-1.fc19.i686 conflicts with file from package PackageKit-0.8.9-1.fc19.x86_64
  file /usr/lib/python2.7/site-packages/packagekit/backend.pyo from install of PackageKit-0.8.9-1.fc19.i686 conflicts with file from package PackageKit-0.8.9-1.fc19.x86_64
  file /usr/lib/python2.7/site-packages/packagekit/enums.pyc from install of PackageKit-0.8.9-1.fc19.i686 conflicts with file from package PackageKit-0.8.9-1.fc19.x86_64
  file /usr/lib/python2.7/site-packages/packagekit/enums.pyo from install of PackageKit-0.8.9-1.fc19.i686 conflicts with file from package PackageKit-0.8.9-1.fc19.x86_64
  file /usr/lib/python2.7/site-packages/packagekit/filter.pyc from install of PackageKit-0.8.9-1.fc19.i686 conflicts with file from package PackageKit-0.8.9-1.fc19.x86_64
  file /usr/lib/python2.7/site-packages/packagekit/filter.pyo from install of PackageKit-0.8.9-1.fc19.i686 conflicts with file from package PackageKit-0.8.9-1.fc19.x86_64
  file /usr/lib/python2.7/site-packages/packagekit/misc.pyc from install of PackageKit-0.8.9-1.fc19.i686 conflicts with file from package PackageKit-0.8.9-1.fc19.x86_64
  file /usr/lib/python2.7/site-packages/packagekit/misc.pyo from install of PackageKit-0.8.9-1.fc19.i686 conflicts with file from package PackageKit-0.8.9-1.fc19.x86_64
  file /usr/lib/python2.7/site-packages/packagekit/package.pyc from install of PackageKit-0.8.9-1.fc19.i686 conflicts with file from package PackageKit-0.8.9-1.fc19.x86_64
  file /usr/lib/python2.7/site-packages/packagekit/package.pyo from install of PackageKit-0.8.9-1.fc19.i686 conflicts with file from package PackageKit-0.8.9-1.fc19.x86_64
  file /usr/lib/python2.7/site-packages/packagekit/progress.pyc from install of PackageKit-0.8.9-1.fc19.i686 conflicts with file from package PackageKit-0.8.9-1.fc19.x86_64
  file /usr/lib/python2.7/site-packages/packagekit/progress.pyo from install of PackageKit-0.8.9-1.fc19.i686 conflicts with file from package PackageKit-0.8.9-1.fc19.x86_64

# yum list PackageKit
Loaded plugins: auto-update-debuginfo, langpacks, refresh-packagekit
Installed Packages
PackageKit.x86_64                     0.8.9-1.fc19                     installed
Available Packages
PackageKit.i686                       0.8.9-1.fc19                     fedora
Comment 1 Michael Schwendt 2013-06-10 03:08:36 EDT
$ repoquery --exactdeps --whatrequires PackageKit
PackageKit-docs-0:0.8.9-1.fc19.noarch
gnome-packagekit-0:3.8.1-1.fc19.x86_64
gnome-packagekit-0:3.8.2-1.fc19.x86_64
mate-applet-softupd-0:0.2.7-1.fc19.x86_64

$ repoquery --whatprovides PackageKit
PackageKit-0:0.8.9-1.fc19.i686
PackageKit-0:0.8.9-1.fc19.i686
PackageKit-0:0.8.9-1.fc19.x86_64
PackageKit-0:0.8.9-1.fc19.x86_64
Comment 2 Richard Hughes 2013-12-11 04:13:41 EST
Yup, this is by design. You can't have two packages providing the same binary name in different arches. PackageKit-glib-libs is multiarch tho, which is how it's supposed to be.
Comment 3 Michael Schwendt 2013-12-11 04:52:00 EST
It's a packaging bug somewhere, because "PackageKit.i686" should not be pulled in by the multiarch compose tool, if the package set is done properly:

Look at this:

  # repoquery --whatrequires PackageKit.i686
  PackageKit-backend-devel-0:0.8.14-3.fc20.i686
  PackageKit-docs-0:0.8.14-3.fc20.noarch
  gnome-packagekit-0:3.10.1-1.fc20.x86_64
  mate-applet-softupd-0:0.2.8-2.fc20.x86_64
  mate-applet-softupd-0:0.2.10-1.fc20.x86_64

How to interpret that? Default for repoquery is --alldeps, so the output means there are dependencies that "Requires: PackageKit" instead of "Requires: PackageKit%{?_isa}".

Low-hanging fruit:

1) The PackageKit-docs subpackage ought not contain an arch-independent "Requires. PackageKit". HTML documentation may be read with any browser and does not strictly require the PackageKit base package to be installed. That's a rule of thumb for Documentation sub-packages.

2) Package "gnome-packagekit" and "mate-applet-softupd" also contain arch-independent Requires, which don't use %?_isa. Please fix them.
Comment 4 Michael Schwendt 2013-12-11 04:59:58 EST
diff --git a/PackageKit.spec b/PackageKit.spec
index 9870db9..b941a20 100644
--- a/PackageKit.spec
+++ b/PackageKit.spec
@@ -115,8 +115,7 @@ A backend for PackageKit to enable Hawkey functionality.
 
 %package docs
 Summary: Documentation for PackageKit
-Group: Development/Libraries
-Requires: %{name} = %{version}-%{release}
+Group: Documentation
 BuildArch: noarch
 
 %description docs
Comment 5 Michael Schwendt 2013-12-15 08:06:14 EST
Fixed in Rawhide, leaving F-20 up to maintainers.

Note You need to log in before you can comment on or make changes to this bug.