Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 972575 - When hostname contains capital letters, UI raises Relay party error on login
When hostname contains capital letters, UI raises Relay party error on login
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Infrastructure (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: Unused
Assigned To: Marek Hulan
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 03:10 EDT by Sachin Ghai
Modified: 2014-04-24 13:08 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-24 13:08:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Relay party not trusted error (28.71 KB, image/png)
2013-06-10 03:10 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2013-06-10 03:10:47 EDT
Created attachment 759062 [details]
Relay party not trusted error

Description of problem:
I was verifying bz 948754, and found this issue. I installed a fresh node of rhel6.4 having hostname in capital letters (HOST166.englab.pnq.redhat.com).

I installed all required packages are ran katello-configure and foreman-proxy-configure. However when I login to ui, I got following error:

-
Relay Party https://host166.englab.pnq.redhat.com not trusted, consult SSO configuration.
-

Version-Release number of selected component (if applicable):
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10002-44.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-postgresql-1.1.10002-44.noarch
* foreman-proxy-1.1.10002-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-8.f5ae2cd.el6sat.noarch
* katello-1.4.2-8.el6sat.noarch
* katello-all-1.4.2-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-6.el6sat.noarch
* katello-cli-common-1.4.2-6.el6sat.noarch
* katello-common-1.4.2-8.el6sat.noarch
* katello-configure-1.4.3-12.el6sat.noarch
* katello-configure-foreman-1.4.3-12.el6sat.noarch
* katello-foreman-all-1.4.2-8.el6sat.noarch
* katello-glue-candlepin-1.4.2-8.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-8.el6sat.noarch
* katello-glue-pulp-1.4.2-8.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.1-1.el6sat.noarch
* pulp-selinux-2.1.1-1.el6sat.noarch
* pulp-server-2.1.1-1.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
* ruby193-rubygem-net-ldap-0.2.2-7.el6_4.noarch
* signo-0.0.15-1.el6sat.noarch
* signo-katello-0.0.15-1.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. Install satellite6 MDP1 build on a system whose hostname contains capital letters.
2.
3.

Actual results:
Unable to login and UI pops-up this msg:

-
Relay Party https://host166.englab.pnq.redhat.com not trusted, consult SSO configuration.
-

Expected results:
User should be able to login

Additional info:
When we disable the sso from /etc/katello/katello.yml, I can successfully login.
Comment 1 RHEL Product and Program Management 2013-06-12 14:33:36 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Marek Hulan 2013-09-03 03:03:24 EDT
PR https://github.com/Katello/signo/pull/18
Comment 7 Sachin Ghai 2013-10-22 04:38:30 EDT
Installed satellite6 MDP2 build on a system having capital letter in its hostname.

the build I installed is satellite6 compose3.

Initializing Katello data: |=========================================================================================================================|
Katello configuration: |=============================================================================================================================|
Katello configuration: |=============================================================================================================================|

[root@HOST201-143 ~]# rpm -qa | grep katello
katello-1.4.6-44.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-configure-1.4.7-7.el6sat.noarch
katello-glue-elasticsearch-1.4.6-44.el6sat.noarch
katello-foreman-all-1.4.6-44.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
katello-common-1.4.6-44.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-configure-foreman-1.4.7-7.el6sat.noarch
katello-cli-1.4.3-26.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-glue-pulp-1.4.6-44.el6sat.noarch
katello-glue-candlepin-1.4.6-44.el6sat.noarch
katello-cli-common-1.4.3-26.el6sat.noarch
katello-all-1.4.6-44.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch
[root@HOST201-143 ~]# 


The build was installed successfully and I can login to UI without any error.
Comment 8 Sachin Ghai 2013-10-22 04:41:39 EDT
Verified with snap6 compose3 (MDP2).
Comment 9 Mike McCune 2014-01-16 16:16:44 EST
removing signo component and moving these bugs to 'Infrastructure'
Comment 12 Bryan Kearney 2014-04-24 13:08:16 EDT
This was verified and delivered with MDP2. Closing it out.

Note You need to log in before you can comment on or make changes to this bug.