Bug 9726 - /bin/kill -l gives wierd output
/bin/kill -l gives wierd output
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-23 16:59 EST by Richard Troxel
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-23 16:59:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Troxel 2000-02-23 16:59:27 EST
On 6.0 systems with util-linux-2.9o-13, the lists output by /bin/kill -l
versus kill -l using the (tcsh) built-in are startlingly different:

% /bin/kill -l
HUP INT QUIT ILL ABRT FPE KILL SEGV PIPE ALRM TERM USR1 USR2 CHLD CONT
STOP TSTP TTIN TTOU TRAP IOT BUS STKFLT URG IO POLL CLD XCPU XFSZ
VTALRM PROF PWR WINCH UNUSED
% kill -l
HUP INT QUIT ILL TRAP ABRT BUS FPE KILL USR1 SEGV USR2 PIPE ALRM TERM
STKFLT CHLD CONT STOP TSTP TTIN TTOU URG XCPU XFSZ VTALRM PROF WINCH POLL
PWR UNUSED RTMIN RTMIN+1 RTMIN+2 RTMIN+3 RTMAX-3 RTMAX-2 RTMAX-1 RTMAX

The former seems really scary -- e.g. SIGKILL is listed 7th not 9th.
Either /bin/kill's -l output is lying, which could be very dangerous; or
/bin/kill is inconsistent with the built-in, which seems almost as
dangerous!
Comment 1 Jeff Johnson 2000-07-27 20:07:29 EDT
util-linux kill has it's own internal table (with holes) of ("string", signal}
tuple's, while tcsh's
output appears to be driven by #ifdef compile checks on adding "string" to an
array
indexed by signal (if signal exists). This leads to different output, but the
Right Thing
happens with both kill and tcsh, since in each case the string entered on the
command
line is translated correctly to the correct signal number.

Note You need to log in before you can comment on or make changes to this bug.