Bug 972638 - Fact editor rejects creation of a declarative model which fact name already exists in a different package
Fact editor rejects creation of a declarative model which fact name already e...
Status: CLOSED NOTABUG
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
5.x.x
Unspecified Unspecified
unspecified Severity medium
: ER1
: ---
Assigned To: Walter Medvedeo
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 05:55 EDT by Toshiya Kobayashi
Modified: 2013-11-18 07:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-02 10:41:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker GUVNOR-2018 Major Resolved Fact editor rejects creation of a declarative model which fact name already exists in a different package 2013-11-18 08:53:25 EST

  None (edit)
Description Toshiya Kobayashi 2013-06-10 05:55:40 EDT
Description of problem:

Platform BZ for https://issues.jboss.org/browse/GUVNOR-2018


Steps to Reproduce:

See GUVNOR-2018

Actual results:

Error popup shows up "The name 'MyFactType1' is already taken - please choose another"

Expected results:

A fact type is successfully created.
Comment 2 Edson Tirelli 2013-08-02 09:54:51 EDT
Not applicable to 6.0.x, as it now uses a new data modeller.
Comment 3 Lukáš Petrovický 2013-08-02 10:41:50 EDT
Agreed.
Comment 4 JBoss JIRA Server 2013-08-19 04:54:42 EDT
David LANTERI <david.lanteri@orange.com> made a comment on jira GUVNOR-2018

Hi,
I'm facing the problem in Drools 5.5.0 Final with a single package :
I archive the declarative model (because of a build package failure) and delete it from Archive, then I recreate it.
When adding a new fact type to it, I get the message :
« The name ‘stabilityResult’ is already taken – please choose another ».

Please, could you help ?
Best regards,
David.
Comment 5 JBoss JIRA Server 2013-11-18 07:01:54 EST
Michael Anstis <michael.anstis@gmail.com> updated the status of jira GUVNOR-2018 to Resolved
Comment 6 JBoss JIRA Server 2013-11-18 07:01:54 EST
Michael Anstis <michael.anstis@gmail.com> made a comment on jira GUVNOR-2018

6.0.x has a new Data Modeller, that replaces the old Fact Modeller. This generates Java classes. The check for an existing asset name no longer applies.

Note You need to log in before you can comment on or make changes to this bug.