Bug 972733 - guest-agent fails to install in automatic provision installation in si29
guest-agent fails to install in automatic provision installation in si29
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent (Show other bugs)
3.1.4
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.2.2
Assigned To: Vinzenz Feenstra [evilissimo]
Jiri Belka
virt
: Regression, ZStream
Depends On:
Blocks: 975433 975906 975912
  Show dependency treegraph
 
Reported: 2013-06-10 09:41 EDT by Attila Darazs
Modified: 2015-09-22 09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The rhevm-guest-agent previously caused installations via kickstart files to fail when installed in the initial installation, this regression has been fixed.
Story Points: ---
Clone Of:
: 975433 975906 (view as bug list)
Environment:
Last Closed: 2013-06-27 11:32:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Attila Darazs 2013-06-10 09:41:21 EDT
Description of problem:
We were using the %packages section of the kickstart file to install the guest-agent on our VMs during installation. This worked fine until si28.2, and started failing on si29 build.

Version-Release number of selected component (if applicable):
3.1.5 candidate (si29)

How reproducible:
Always

Steps to Reproduce:
1. do a kickstart automation installation with the following packages section:

%packages
@core
rhevm-guest-agent

Actual results:
installation fails with "A fatal error occurred when installing the rhevm-guest-agent package. This could indicate errors when reading the installation media. Installation cannot continue. [Exit installer]"

Expected results:
Installation succeeds.

Additional info:
In the installation script of the rhevm-guest-agent package, /sbin/service is called to check whether there was rhev-agentd running. The file is not there in the anaconda installer environment in the latest RHEL 6.4.
Comment 1 Michal Skrivanek 2013-06-11 00:51:08 EDT
issue with old rhev agent service detection. Should be an easy fix
Comment 4 Michal Skrivanek 2013-06-12 01:02:57 EDT
I understand the issue now - the pretransaction rpm code cannot run during kickstart installs as there is no bash, nothing. We have 2 options - rewrite the code in lua or remove it completely and update relnotes to just start the agent after upgrade from 3.0 agent. I'm in favor of the latter since that's upstream way and also this won't be an issue for 3.1. OTOH the udevtrigger needs to get executed as well if we don't reboot...
Barak, what do you think?
Comment 5 Michal Skrivanek 2013-06-12 01:03:58 EDT
disregard the udevtrigger comment, that's in "post" so no issue there. One more reason to get rid of that;-)
Comment 8 Vinzenz Feenstra [evilissimo] 2013-06-21 03:08:30 EDT
Removing needinfo, this has been solved.
Comment 11 Jiri Belka 2013-06-24 10:04:40 EDT
ok, 1.0.7-12.el6ev
Comment 13 errata-xmlrpc 2013-06-27 11:32:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0991.html

Note You need to log in before you can comment on or make changes to this bug.