Bug 972767 - Saving a process does not reload the Problems detected
Saving a process does not reload the Problems detected
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: jBPM Designer (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity medium
: ER1
: 6.0.0
Assigned To: Tihomir Surdilovic
Zuzana Krejčová
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 10:38 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:07:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zuzana Krejčová 2013-06-10 10:38:11 EDT
Description of problem:
When you create any type of asset, Problems tab is opened. This of course happens for new processes as well, in their case the Problems tab even shows that the start and end nodes are missing for the new process. If you fix that and save the process, the problems reported do not disappear (from the Problems tab). 
The problems detected are refreshed upon saving an asset through the menu bar, File - Save, which is unfortunately unavailable for processes.
This means that you cannot build and deploy a project/artefact with a new process until you save another asset (e.g. pom.xml, task form, ...).


Version-Release number of selected component (if applicable):
BPMS 6, DR5


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Tihomir Surdilovic 2013-06-19 13:03:09 EDT
The Problems tab should not be shown by UF in case of bpmn2 assets. Designer currently still has its own visual validation mechanism. I would suggest not making this a Designer BZ since it does not control this tab. Would be nice if in UF we can control its showing up or not.
Comment 5 Lukáš Petrovický 2014-02-07 11:15:56 EST
This BZ has been part of the 6.0.0 stream.

Note You need to log in before you can comment on or make changes to this bug.