Bug 972858 - anaconda "Please complete items marked" message when not needed
anaconda "Please complete items marked" message when not needed
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: 920743
  Show dependency treegraph
 
Reported: 2013-06-10 12:23 EDT by Russ Anderson
Modified: 2013-08-07 20:02 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 20:02:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen snap showing the error message (75.70 KB, image/png)
2013-06-10 12:40 EDT, Russ Anderson
no flags Details
[F19 Final DVD] screenshot showing configuration hub during package installation (153.86 KB, image/png)
2013-07-16 00:05 EDT, Steve Tyler
no flags Details

  None (edit)
Description Russ Anderson 2013-06-10 12:23:11 EDT
Description of problem:  While installing anaconda still displays the yellow "Please complete the items marked with this icon before continuing to the next step." message even while installing.


Version-Release number of selected component (if applicable): FC-19


How reproducible: 100%


Steps to Reproduce:
1. Install with the new anaconda.
2.
3.

Actual results: The unnecessary, annoying message.


Expected results:  No unnecessary, annoying message.


Additional info:  While the message does not seem to be harmful to the install, it is harmful to anaconda's reputation.  It makes anaconda look not ready for prime time (to put it politely).
Comment 1 Russ Anderson 2013-06-10 12:40:00 EDT
Created attachment 759268 [details]
screen snap showing the error message
Comment 2 Russ Anderson 2013-06-18 10:56:59 EDT
Add to the rhel7 tracker.
Comment 3 Brian Lane 2013-07-15 20:38:49 EDT
The version you are using is missing the orange triangles (they are grey in your image), you need to either set a root pw or setup a user and you haven't done either. The final release has the correct icons.
Comment 4 Steve Tyler 2013-07-15 21:48:55 EDT
(In reply to Brian C. Lane from comment #3)
> The version you are using is missing the orange triangles (they are grey in
> your image), you need to either set a root pw or setup a user and you
> haven't done either. The final release has the correct icons.

The resolution here should be CURRENTRELEASE, instead of NOTABUG.
https://bugzilla.redhat.com/page.cgi?id=fields.html#status
Comment 5 Russ Anderson 2013-07-15 23:38:11 EDT
Hi Brian.  Apparently I was not clear about the problem.  There seems to be two actions going on on the screen.  One is that the packages are being installed.  The other is a message asking for user input before continuing.

The confusion is that the package installation messages makes it look like the install is continuing while the yellow "Please complete the items marked" message makes it look like user action is needed to continue.  It is not clear that the user name and password can be set by the user while the packages are installing.

Now that Anaconda is multi-threaded, it is really important to make sure messages are clear as to which (of the several actions) the message is referring to.

Since you are familiar with Anaconda, it may seem obvious to you.  But for me, coming from the old Anaconda world where one thing happens at a time, it was confusing.
Comment 6 Steve Tyler 2013-07-16 00:05:00 EDT
Created attachment 774004 [details]
[F19 Final DVD] screenshot showing configuration hub during package installation

For reference, here is the configuration hub during package installation from the F19 Final DVD. Orange triangles mark the root password and user creation links.

Tested with:
$ qemu-kvm -m 4096 -hda f19-test-2.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on
Comment 7 Steve Tyler 2013-07-16 00:09:58 EDT
The message at the bottom of the screen says:

"Please complete items marked with this icon before continuing to the next step."

What is the name of "this icon"?

Russ: Do you interpret the orange triangle as signifying an error?
Comment 8 Russ Anderson 2013-07-16 00:24:21 EDT
> Russ: Do you interpret the orange triangle as signifying an error?

Yes.  I interpret it as something that the user has done wrong.  It also strikes me as rude for Anaconda to complain that a root password and user have not been created BEFORE giving the user a chance to create them.

Why not ask the user to create a root password and user before complaining that it hasn't been done?
Comment 9 Russ Anderson 2013-07-16 01:09:34 EDT
Reopen.  The problem isn't grey vs orange triangles.
The problem is a confusing interface.
Comment 10 Steve Tyler 2013-07-16 01:21:57 EDT
Good points.

When the installer tells the user to "complete items marked with this icon", it is misleading the user as to what actually needs to be done to complete the install:

The root password can be set
OR
An administrator user can be created.

That is, both marked items do not need to be completed.

If a non-administrator user is created, however, a root password must be set to complete the install.

Tested with:
$ qemu-kvm -m 4096 -hda f19-test-2.img -cdrom ~/xfr/fedora/F19/Fedora-19-x86_64-DVD.iso -vga std -boot menu=on

Note You need to log in before you can comment on or make changes to this bug.