Bug 972880 - ISO files become zero-byte when syncing from local published ISO repo
ISO files become zero-byte when syncing from local published ISO repo
Status: CLOSED UPSTREAM
Product: Pulp
Classification: Community
Component: iso-support (Show other bugs)
unspecified
Unspecified Unspecified
high Severity medium
: ---
: 2.6.0
Assigned To: Jeremy Cline
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 13:48 EDT by Preethi Thomas
Modified: 2015-02-28 16:56 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-28 16:56:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Pulp Redmine 354 None None None Never

  None (edit)
Description Preethi Thomas 2013-06-10 13:48:44 EDT
Description of problem:

iso repo sync failing with local feed

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. I created and synced an iso repo

[root@hp-dl360g6-01 ~]# ls -l /var/lib/pulp/published/https/isos/iso.repo/
total 16
-rw-r--r--. 1 apache apache 251 Jun 10 13:07 PULP_MANIFEST
lrwxrwxrwx. 1 apache apache 118 Jun 10 13:07 test2.iso -> /var/lib/pulp/content/iso/test2.iso/042c259d546331588e1dff83a46f62a27fb7cf3de4050924470d99fd8d2a046f/4358144/test2.iso
lrwxrwxrwx. 1 apache apache 118 Jun 10 13:07 test3.iso -> /var/lib/pulp/content/iso/test3.iso/f56e08898287e60b3169392351e9296bbe28417db1f8e34e8058d124be89b93a/3244032/test3.iso
lrwxrwxrwx. 1 apache apache 116 Jun 10 13:07 test.iso -> /var/lib/pulp/content/iso/test.iso/582f1729b0c15eacbb7d02a553c0a96a39f817135c15ac4190aef96e45c4b65d/3145728/test.iso

2. Create a second repo with local feed to the above repo locations

[root@hp-dl360g6-01 ~]# pulp-admin iso  repo create --repo-id local-iso --feed file:////var/lib/pulp/published/https/isos/iso.repo/
Successfully created repository [local-iso]

3. Sync that repo 
[root@hp-dl360g6-01 ~]# pulp-admin iso repo sync run  --repo-id local-iso
+----------------------------------------------------------------------+
                  Synchronizing Repository [local-iso]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading the Pulp Manifest failed:

	None


Actual results:


Expected results:


Additional info:
Comment 1 Chris Duryee 2014-11-07 16:34:26 EST
Tested with Pulp 2.5.0-0.17.rc

I was able to sync locally from a repo under /tmp with success after disabling selinux. However, when I tried to sync again from the published directory (step #2 in original report), my iso files under /var/lib/pulp/content became zero-byte.
Comment 2 Chris Duryee 2014-11-07 16:38:19 EST
I am not sure about the severity of this bz. Removing triaged tag so this gets re-triaged.
Comment 3 Jeremy Cline 2014-11-24 14:12:32 EST
https://github.com/pulp/pulp_rpm/pull/601
Comment 4 Chris Duryee 2014-12-23 15:53:03 EST
fixed in pulp 2.6.0-0.2.beta
Comment 5 Preethi Thomas 2015-01-28 09:32:22 EST
[root@gizmo ~]# rpm -qa pulp-server
pulp-server-2.6.0-0.5.beta.el6.noarch
[root@gizmo ~]# 

[root@gizmo ~]# pulp-admin iso  repo create --repo-id local-iso --feed file:////var/lib/pulp/published/https/isos/iso/
Warning: path should have mode 0700 because it may contain sensitive information: /root/.pulp/

Successfully created repository [local-iso]

[root@gizmo ~]# 
[root@gizmo ~]# 
[root@gizmo ~]# ls -l /var/lib/pulp/published/https/isos/iso/total 16
-rw-r--r--. 1 apache apache 251 Jan 26 10:19 PULP_MANIFEST
lrwxrwxrwx. 1 apache apache 118 Jan 26 10:19 test2.iso -> /var/lib/pulp/content/iso/test2.iso/042c259d546331588e1dff83a46f62a27fb7cf3de4050924470d99fd8d2a046f/4358144/test2.iso
lrwxrwxrwx. 1 apache apache 118 Jan 26 10:19 test3.iso -> /var/lib/pulp/content/iso/test3.iso/f56e08898287e60b3169392351e9296bbe28417db1f8e34e8058d124be89b93a/3244032/test3.iso
lrwxrwxrwx. 1 apache apache 116 Jan 26 10:19 test.iso -> /var/lib/pulp/content/iso/test.iso/582f1729b0c15eacbb7d02a553c0a96a39f817135c15ac4190aef96e45c4b65d/3145728/test.iso
[root@gizmo ~]# 
[root@gizmo ~]# 

[root@gizmo ~]# 
[root@gizmo ~]# 
[root@gizmo ~]# pulp-admin iso repo sync run --repo-id local-iso
Warning: path should have mode 0700 because it may contain sensitive information: /root/.pulp/

+----------------------------------------------------------------------+
                  Synchronizing Repository [local-iso]
+----------------------------------------------------------------------+

This command may be exited via ctrl+c without affecting the request.


The Pulp Manifest was downloaded successfully.

There are no ISOs that need to be downloaded.


Task Succeeded



The repository was successfully published.


Task Succeeded


[root@gizmo ~]# pulp-admin iso repo list
Warning: path should have mode 0700 because it may contain sensitive information: /root/.pulp/

+----------------------------------------------------------------------+
                            ISO Repositories
+----------------------------------------------------------------------+

Id:                  iso
Display Name:        iso
Description:         None
Content Unit Counts: 
  Iso: 3

Id:                  local-iso
Display Name:        local-iso
Description:         None
Content Unit Counts: 
  Iso: 3


[root@gizmo ~]#
Comment 6 Brian Bouterse 2015-02-28 16:56:38 EST
Moved to https://pulp.plan.io/issues/354

Note You need to log in before you can comment on or make changes to this bug.