Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 972994 - 4.11.1 does not allow "%files -n %{name}"?
4.11.1 does not allow "%files -n %{name}"?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-10 23:11 EDT by Jens Petersen
Modified: 2013-06-13 02:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 03:19:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2013-06-10 23:11:36 EDT
Description of problem:
Today I built a new package in koji for f17, f18, f19 and el6,
but it fails to build in rawhide seemingly because rpmbuild
is no longer accepting "%files -n %{name}".

Version-Release number of selected component (if applicable):
rpm-4.11.1-0.rc1.1.fc20

How reproducible:
every time

Steps to Reproduce:
1. build package with (implicit) %files -n %{name}

Actual results:
error: line 49: Package does not exist: %files -n ghc-setenv -f ghc-setenv.files
(the src package is ghc-setenv in this case)

http://kojipkgs.fedoraproject.org//work/tasks/9376/5489376/build.log

http://koji.fedoraproject.org/koji/packageinfo?packageID=16353

Expected results:
no error

Additional info:
This seems to be new to 4.11.1.
It is not really a big deal for me since Haskell templates are
changing anyway to new simplified Haskell Packaging Guidelines,
but anyway this seems like a change of behaviour/regression.
Comment 1 Panu Matilainen 2013-06-11 02:18:41 EDT
This is a regression alright, will fix. Thanks for reporting!
Comment 2 Panu Matilainen 2013-06-11 03:19:34 EDT
Fixed in rpm-4.11.1-0.rc1.2.fc20. And again, thanks for reporting. This is just the kind of stuff I wanted to catch with the rc :)
Comment 3 Jens Petersen 2013-06-13 02:55:10 EDT
Thanks

http://koji.fedoraproject.org/koji/taskinfo?taskID=5498348

Note You need to log in before you can comment on or make changes to this bug.