Bug 973043 - syntax error in a config file is breaking libreoffice build
syntax error in a config file is breaking libreoffice build
Status: CLOSED DUPLICATE of bug 972717
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: java-1.7.0-openjdk (Show other bugs)
7.0
All Unspecified
high Severity urgent
: rc
: ---
Assigned To: Andrew John Hughes
BaseOS QE - Apps
:
Depends On:
Blocks: 971896
  Show dependency treegraph
 
Reported: 2013-06-11 03:13 EDT by David Tardon
Modified: 2013-06-11 11:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-11 11:43:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Tardon 2013-06-11 03:13:57 EDT
Description of problem:
https://brewweb.devel.redhat.com/taskinfo?taskID=5885621 failed on ppc in

S=/builddir/build/BUILD/libreoffice-4.1.0.0.beta2 && O=$S/solver/unxlngppc.pro  && W=$S/workdir/unxlngppc.pro &&  mkdir -p $W/JavaClassSet/Jar/sdbc_hsqldb/ &&   rm -rf $W/JavaClassSet/Jar/sdbc_hsqldb/* && RESPONSEFILE=/tmp/gbuild.70Zee1 &&  /usr/bin/javac  -source 1.5 -target 1.5 -Xlint:-options -g -classpath "$O/bin/hsqldb.jar:$W/JavaClassSet/Jar/sdbc_hsqldb" -d $W/JavaClassSet/Jar/sdbc_hsqldb @$RESPONSEFILE && rm -f $RESPONSEFILE && touch $W/JavaClassSet/Jar/sdbc_hsqldb/done

with the following exception

java.lang.ExceptionInInitializerError
         at java.nio.file.Files.createTempFile(Files.java:803)
         at sun.tools.jar.Main.createTempFileInSameDirectoryAs(Main.java:140)
         at sun.tools.jar.Main.run(Main.java:212)
         at sun.tools.jar.Main.main(Main.java:1177)
 Caused by: java.security.ProviderException: Error parsing configuration
         at sun.security.pkcs11.Config.getConfig(Config.java:88)
         at sun.security.pkcs11.SunPKCS11.<init>(SunPKCS11.java:128)
         at sun.security.pkcs11.SunPKCS11.<init>(SunPKCS11.java:103)
         at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method )
         at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstruc torAccessorImpl.java:57)
         at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Delegating ConstructorAccessorImpl.java:45)
         at java.lang.reflect.Constructor.newInstance(Constructor.java:525)
         at sun.security.jca.ProviderConfig$2.run(ProviderConfig.java:224)
         at sun.security.jca.ProviderConfig$2.run(ProviderConfig.java:206)
         at java.security.AccessController.doPrivileged(Native Method)
         at sun.security.jca.ProviderConfig.doLoadProvider(ProviderConfig.java:2 06)
         at sun.security.jca.ProviderConfig.getProvider(ProviderConfig.java:187)
         at sun.security.jca.ProviderList.getProvider(ProviderList.java:232)
         at sun.security.jca.ProviderList$3.get(ProviderList.java:147)
         at sun.security.jca.ProviderList$3.get(ProviderList.java:142)
         at java.util.AbstractList$Itr.next(AbstractList.java:358)
         at java.security.SecureRandom.getPrngAlgorithm(SecureRandom.java:542)
         at java.security.SecureRandom.getDefaultPRNG(SecureRandom.java:187)
         at java.security.SecureRandom.<init>(SecureRandom.java:155)
         at java.nio.file.TempFileHelper.<clinit>(TempFileHelper.java:56)
         ... 4 more
 Caused by: sun.security.pkcs11.ConfigurationException: Invalid value for handle StartupErrors: Token[ignoreMultipleInitialisation], line 5
         at sun.security.pkcs11.Config.excToken(Config.java:367)
         at sun.security.pkcs11.Config.parseHandleStartupErrors(Config.java:984)
         at sun.security.pkcs11.Config.parse(Config.java:404)
         at sun.security.pkcs11.Config.<init>(Config.java:216)
         at sun.security.pkcs11.Config.getConfig(Config.java:84)
         ... 23 more

Version-Release number of selected component (if applicable):
java-1.7.0-openjdk-devel-1.7.0.19-2.3.9.14.el7.ppc

How reproducible:
always, apparently

Steps to Reproduce:
1. run a build of libreoffice in brew

Additional info:
Repeated build (https://brewweb.devel.redhat.com/taskinfo?taskID=5889824) failed on x86_64 and i386 too.
Comment 2 Deepak Bhole 2013-06-11 07:47:31 EDT
Doesn't look like a PPC specific error. Assigning to Andrew Hughes for initial assessment.

Andrew, if the bug is due to Zero, please are-assign it to Chris.
Comment 3 Andrew John Hughes 2013-06-11 11:43:43 EDT
Same packaging issue as RH 972717.

*** This bug has been marked as a duplicate of bug 972717 ***

Note You need to log in before you can comment on or make changes to this bug.