Bug 973114 - [RHS-C] Resolve Content Conflict is incorrectly showing the status of a hook as "Missing" in some servers even though there isn't any Missing
[RHS-C] Resolve Content Conflict is incorrectly showing the status of a hook ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Sahina Bose
Prasanth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 06:06 EDT by Prasanth
Modified: 2013-09-23 18:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: bb6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of error (33.27 KB, image/png)
2013-06-11 06:06 EDT, Prasanth
no flags Details

  None (edit)
Description Prasanth 2013-06-11 06:06:53 EDT
Created attachment 759544 [details]
screenshot of error

Description of problem:

Resolve Content Conflict is incorrectly showing the status of a hook as "Missing" in some servers even though the hook is present in those servers and ONLY the content is different.


Version-Release number of selected component (if applicable):  Red Hat Storage Console Version: 2.1.0-0.bb2.el6rhs 


How reproducible: Always


Steps to Reproduce:

Create a 3 server cluster.

1. Create a Text Hook (say: S34testhook.sh) in one of the servers and sync it across all the servers using the Resolve Conflict Missing feature.

2. Copy a Binary Hook to server1 with the same name as that of the Text Hook (S34testhook.sh). So currently, Server1 is having a binary hook with the name S34testhook.sh; server2 and server3 are having a text hook with the same name (S34testhook.sh)

3. A content conflict will now be determined in the UI and is supposed to be between the Engine and the 3 servers.

4. Now click on "Resolve Conflicts".



Actual results: 
You will see that the "Status" of the Engine (Master) copy and server1 copy is "Enabled", whereas the status of server2 and server3 is "Missing" eventhough it is supposed to be "Enabled" as it's just a "Content Conflict" and NOT a "Missing Conflict"


Expected results: For a Content conflict, the Status of the hook shouldn't be "Missing" unless there is ANY missing 

------------
From Server1:

[root@qa-vm05 post]# ll
total 304
-rwxr--r--. 1 root root  3050 May 10 10:05 S30samba-set.sh
-rwx------  1 root root 99000 Jun  6 20:39 S32binaryhooknew.sh
-rwx------  1 root root 99000 Jun 10 17:57 S32binaryhookold.sh
-rwx------  1 root root 99000 Jun  6 20:39 S34testhook.sh

[root@qa-vm05 post]# head -3 S34testhook.sh
ELF>�$@@�z@@ @@@@@�@@@@\Y\Y `Y`Ya`Ya▒▒ �]�]a�]a�@@DDP�tdT6T6AT6A��Q�t/lib64/ld-linux-x86-64.so.2GNUGNUt�c��K?�(O�9J!�']"p@ 0@pr�        2�G-��>K��c*+Ը����p^C+=e
                                                                                                                                                                 ��8cG��f'6�I���
�7��FDT3Rx�"����t�x1q�E"�����▒���;P+����qV��Lz�"������B�|K�����▒f�/n�G�,S▒Hd`▒Pdam`/A/��▒@d��Q§�=��Q�Ұ���Q������Q˸�n8`a%P&0�`a&0`aa%&0�aa%�&0 ba%��&0�ba%��&0�ba%�&0�ba%�&0�p '0%&00�8&0��������8�8&0��������@�8&0`�8&0��������x�8&0��������p�8&0��������x�8&0���������8&0��������H�8&0��������X�8&0����������8&0��������▒�8&0%�&00�8&0%@&0��&0����������ti��&0��u▒i���(��_a%P&0耡&0%&0���&0%��&0���%0г&0���%0��&0���%0��&0���%0�&0���%0ж&0���%0ж&0 u▒i �=ii
                    �_a�_a�_a+�_a.�_a4�_ap�_aq�_aB�_ar�_a`�_aa�_as�_at`ao `a(`a0`a8`a@`aH`aP`aX```a     h`a
p`a
   x`a�`a�`a�`a�`a�`a�`a�`a�`a▒�`a�`a▒�`a`a�`a�`a�`a�`a aaaa"aa#▒aa$ aa%(aa&0aa'8aa(@aa)Haa*Paa+Xaa,`aa-haa/paa0xaa1�aa2�aa3�aa5�aa6�aa7�aa8�aa9�aa:�aa;�aa<�aa=�aa>�aa?�aa@�aaA�aaCbabaEbaG▒baH baI(baJ0baK8baL@baMHbaNPbaOXbaP`baQhbaRpbaSxbaT�baU�baV�baW�baX�baY�baZ�ba[�ba\�ba]�ba^�ba_�bab�bac�bad�bae�bafcacahcai▒caj cak(cal0cam8canH����▒���H��5zA!�%|A!@�%zA!h������%rA!h������%jA!h������%bA!h������%ZA!h������%RA!h������%JA!h������%BA!h�p����%:A!�`����%2A!h      �P����%*A!h


From Server2:
[root@qa-vm06 post]# ll
total 208
-rwxr--r--. 1 root root  3050 May 10 10:05 S30samba-set.sh
-rwxr-xr-x  1 root root 99000 May 15 16:51 S32binaryhooknew.sh
-rwx------  1 root root 99000 Jun  6 22:56 S32binaryhookold.sh
-rwx------  1 root root  3050 Jun 10 19:34 S34testhook.sh
[root@qa-vm06 post]# head -3 S34testhook.sh
#!/bin/bash

PROGNAME="Ssamba-set"


From Server3:
[root@qa-vm07 post]# ll
total 208
-rwxr--r--. 1 root root  3050 May 10 10:05 S30samba-set.sh
-rwx------  1 root root 99000 Jun 10 17:57 S32binaryhooknew.sh
-rwx------  1 root root 99000 Jun 10 17:57 S32binaryhookold.sh
-rwx------  1 root root  3050 Jun 10 19:34 S34testhook.sh
[root@qa-vm07 post]# head -3 S34testhook.sh
#!/bin/bash

PROGNAME="Ssamba-set"
-------------


Additional info: Screenshot attached.
Comment 2 Sahina Bose 2013-07-16 02:04:21 EDT
Conflicts are reported correctly now - even when hooks are of different type and file names are the same.
Comment 3 Sahina Bose 2013-07-17 05:45:45 EDT
Fixed in bb6
Comment 4 Prasanth 2013-07-21 00:57:01 EDT
Verified as fixed in bb6
Comment 5 Scott Haines 2013-09-23 18:25:46 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.