Bug 973121 - BeanShell is not present in distribution
Summary: BeanShell is not present in distribution
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: SwitchYard, Configuration (Show other bugs)
(Show other bugs)
Version: 6.0.0 GA
Hardware: Unspecified Unspecified
unspecified
medium
Target Milestone: ER2
: ---
Assignee: tcunning
QA Contact: Jiri Pechanec
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-11 10:29 UTC by Jiri Pechanec
Modified: 2014-06-16 23:53 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SWITCHYARD-1650 None Closed None 2014-06-16 23:53:11 UTC

Description Jiri Pechanec 2013-06-11 10:29:07 UTC
According to PRD SOA-CORE-4 it is required to support Groovy and BeanShell out-of-the-box via Camel routes.

Groovy works
 - is packed as a module in distro
Rhino works
 - verifies that JSR-223 integration is working
BeanShell does not work
 - the problem is that beanshell is no longer delivered with EAP so it should be delivered with SOA-P

Comment 1 Jiri Pechanec 2013-07-22 06:27:39 UTC
BeanShell is now present - unfortunately only in b4 verison, that is not JSR-223 enabled - which means that Camel cannot find it. b5 version contains JSR-223 enabled version.

Comment 2 JBoss JIRA Server 2013-08-21 01:13:33 UTC
Keith Babo <kbabo@redhat.com> made a comment on jira SWITCHYARD-1650

pushed

Comment 3 Jiri Pechanec 2013-09-18 05:24:20 UTC
Verified in ER2

Comment 7 JBoss JIRA Server 2014-06-16 23:53:12 UTC
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1650 to Closed


Note You need to log in before you can comment on or make changes to this bug.