Bug 973134 - [RFE] firewall-config: GUI does not provides 'Connections' summary, no Zone<>Connection setup
[RFE] firewall-config: GUI does not provides 'Connections' summary, no Zone<>...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 06:58 EDT by Petr Sklenar
Modified: 2016-07-15 11:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-15 11:41:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2013-06-11 06:58:37 EDT
Description of problem:
firewall-config: GUI does not provides 'Connections' summary.
My initial use case was about to create bridge for virtual guests.
So I needed to add 'trusted' zone for bridge in the "Network Connection"
Then all seems to be working, virt guests via bridge and zone 'work' for eth0.

The first question is "How can one know that zone for bridge needs to be adjusted via NetworkManager not via firewalld"


How reproducible:
rfe

Steps to Reproduce:
1, have a two connections, one for bridge, another for eth0
2, zone trusted for bridge
3, zone work for eth0
-------
missed features:
4. firewall-config should show any summary with connections and its zones.
  (the same as firewall-applet when you touch the icon)

for ex.: there are mentioned in the left pane, right of "name of the zone"
or there is any view with connections summary and their default zones.

5. you can change zone in NM for selected connection.
firewall-config should change the opposite =>  connections for selected zone.

Version-Release number of selected component (if applicable):
firewalld-0.3.3-1.fc19.noarch


Actual results:
no view of connections in firewall-config


Expected results:
firewall-config shows info about connection and its zone.

The better I can change zones for any of my connections via firewall-config. (which is propagated into NM)

Additional info:
This is just request and probably it needs more investigation.
But connections are really hidden from firewall-config point of view.
Comment 1 Thomas Woerner 2016-07-15 11:41:42 EDT
This has been added with firewalld version 0.4.2.

Note You need to log in before you can comment on or make changes to this bug.