Bug 973196 - Template does not honor original VM's timezone value
Template does not honor original VM's timezone value
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 08:55 EDT by Jiri Belka
Modified: 2015-09-22 09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 05:35:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log (23.51 KB, application/x-tar)
2013-06-11 08:55 EDT, Jiri Belka
no flags Details
engine.log (6.97 KB, application/x-tar)
2013-06-11 08:56 EDT, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2013-06-11 08:55:03 EDT
Created attachment 759622 [details]
vdsm.log

Description of problem:
Template does not honor original VM's timezone value.

I created a Windows XP VM with one disk and one nic, its time zone is null by default. Without starting it, I created template from it. The template does not honor original VM's time zone, its time zone was set to 'GMT Standard Time'.

Version-Release number of selected component (if applicable):
sf17.5

How reproducible:
100%

Steps to Reproduce:
1. create win xp vm
2. do not start it and create template from it
3. compare TZ values in the DB
4. create new VM from this template
5. compare TZ values

Actual results:
template does not honor original VM's TZ

Expected results:
honor TZ

Additional info:

* TZ values in DB

engine=> select vm_name,time_zone from vm_static where vm_name = 'new-wxp';                                                                                    
 vm_name | time_zone 
---------+-----------
 new-wxp | 
(1 row)

engine=> select vm_name,time_zone from vm_static where vm_name = 'templ-new-wxp';                                                                              
    vm_name    |     time_zone     
---------------+-------------------
 templ-new-wxp | GMT Standard Time
(1 row)

engine=> select vm_name,time_zone from vm_static where vm_name = 'tz-new-wxp';
  vm_name   |     time_zone     
------------+-------------------
 tz-new-wxp | GMT Standard Time
(1 row)

* TZ set for starting VMs

[root@dell-r210ii-03 ~]# egrep "\<clock ad.*offset=" /var/log/vdsm/vdsm.log | tail -n2
        <clock adjustment="-14400" offset="variable">
        <clock adjustment="3600" offset="variable">

1. new-wxp = original VM
2. tz-new-wxp = vm created from the template
Comment 1 Jiri Belka 2013-06-11 08:56:13 EDT
Created attachment 759623 [details]
engine.log
Comment 2 Michal Skrivanek 2013-06-13 05:35:56 EDT
behavior caused by bug 873795
3.1 VMs should all have some TZ
earlier 3.2 builds may have null which means default TZ which is correct in your case
in both cases this is actually the right thing

Note You need to log in before you can comment on or make changes to this bug.