Bug 973217 - Packstack fails on puppet's timeout while updating kernel+iputils+iproute
Packstack fails on puppet's timeout while updating kernel+iputils+iproute
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity medium
: beta
: 4.0
Assigned To: Martin Magr
Rami Vaknin
: Triaged
: 981397 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 09:24 EDT by Rami Vaknin
Modified: 2013-12-19 19:05 EST (History)
9 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.1.dev691.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:05:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 37228 None None None Never

  None (edit)
Description Rami Vaknin 2013-06-11 09:24:14 EDT
Version:
Grizzly on rhel6.4, openstack-packstack-2013.1.1-0.15.dev625.el6ost

Description:
Packstack fails on puppet timeout which is 300 seconds for exec by default.
Note that packstack pass successfully when running it again on the same environment.

Proposed solution: add "timeout     => xxx," with xxx greater than 300 seconds.

2013-06-11 15:11:18::ERROR::ospluginutils::144::root:: ESC[1;35merr: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: change from notrun to 0 failed: Command exceeded timeout at /var/tmp/packstack/df8a940550f34629989b
caeb33034bd1/modules/packstack/manifests/netns.pp:13ESC[0m
ESC[0;36mnotice: /Stage[main]/Packstack::Netns/Notify[packstack_info]: Dependency Exec[netns_dependecy_install] has failures: trueESC[0m
ESC[0;33mwarning: /Stage[main]/Packstack::Netns/Notify[packstack_info]: Skipping
 because of failed dependenciesESC[0m
ESC[0;36mnotice: Finished catalog run in 300.15 secondsESC[0m

2013-06-11 15:11:18::ERROR::run_setup::889::root:: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 884, in main
    _main(confFile)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 577, in _main
    runSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 554, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/setup_controller.py", line 90, in runAllSequences
    sequence.run(self.CONF)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 105, in run
    step.run(config=config)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 52, in run
    raise SequenceError(str(ex))
SequenceError: Error during puppet run : err: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: change from notrun to 0 failed: Command exceeded timeout at /var/tmp/packstack/df8a940550f34629989bcaeb33034bd1/modules/packstack/manifests/netns.pp:13ESC[0m
Comment 3 Martin Magr 2013-08-09 09:36:31 EDT
*** Bug 981397 has been marked as a duplicate of this bug. ***
Comment 6 Rami Vaknin 2013-10-16 16:25:53 EDT
Verified on rhos 4.0 running on rhel6.5 with openstack-packstack-2013.2.1-0.6.dev763.el6ost, installation passed successfully.

Since this bug usually does not reproduce easily, I've also checked the code in /usr/lib/python2.6/site-packages/packstack/puppet/modules/packstack/manifests/netns.pp and found a new "timeout => 900" definition.
Comment 9 errata-xmlrpc 2013-12-19 19:05:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.