Bug 973265 - Large custom cartridge hangs on client side when creating application
Large custom cartridge hangs on client side when creating application
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 11:04 EDT by Wesley Hearn
Modified: 2015-05-14 20:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 10:53:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wesley Hearn 2013-06-11 11:04:56 EDT
Description of problem:
When creating an application with my community mono cartridge(125MB) the web console and rhc utils hang despite the application being created succesfully.

Version-Release number of selected component (if applicable):
latest

How reproducible:
always

Steps to Reproduce:
1. Create an application with this cartridge https://raw.github.com/wshearn/openshift-community-cartridge-mono/master/metadata/manifest.yml
2. in another window do while true ; do curl --head <appname>-<namespace>.rhcloud.com ; sleep 1 ; done
3. See the appliction come up but the website or rhc utils never print the final information

Actual results:
The utils hang

Expected results:
Should return post creation application details.

Additional info:
Comment 1 Wesley Hearn 2013-06-14 21:54:24 EDT
So I updated my cartridge and I have not seen this happen again. Not sure if it was mono2 that caused it, I don't think it was but I have been wrong before. 

Closing withinsufficient data until it happens again and we can debug it further.
Comment 2 Wesley Hearn 2013-06-15 23:32:18 EDT
Ok, So I updated the manifest.yml file and this bug is back.
Comment 3 Abhishek Gupta 2013-06-18 12:40:20 EDT
Unable to reproduce this on the dev instance as well as in PROD. Requesting QE to check if they can reproduce this in their environment.
Comment 4 Jianwei Hou 2013-06-19 04:25:42 EDT
Tested on devenv_3382
Could not reproduce this either, mark as verified

Note You need to log in before you can comment on or make changes to this bug.