Bug 97328 - libpng.so.2 missing or missing gimp RPM dependency?
libpng.so.2 missing or missing gimp RPM dependency?
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: gimp (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-12 21:43 EDT by Jonathan Kamens
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-13 10:52:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2003-06-12 21:43:27 EDT
When launching gimp from gimp-1.2.3-20.2:

/usr/lib/gimp/1.2/plug-ins/helpbrowser: error while loading shared libraries:
libpng.so.2: cannot open shared object file: No such file or directory
Comment 1 Alexander Farley 2003-06-13 10:21:42 EDT
Gimp works fine for me as of 6/13/2003 with latest rawhide packages. libpng.so.2
links to libpng.so.2.1.0.13, so the problem would seem to be with libpng10 or
libpng10-devel not being installed. There was a problem with libpng10 and
libpng10-devel not installing a few days ago, but this is fixed as of
libpng10-1.0.13-9.
Comment 2 Jonathan Kamens 2003-06-13 10:52:03 EDT
I found the problem.  I had recently done a clean-up of old RPMs on my machine, 
and I removed libpng10 because rpm claimed it was safe to remove it, i.e., 
nothing else needed it.  It turns out that this was because the 
VMwareWorkstation RPM claims to provide the capability libpng.so.2, but it 
doesn't really because the copy of that library included in the RPM is in a 
private directory.  So this is actually a bug in the VMwareWorkstation RPM, and 
I've filed a bug report with VMware about it.

Note You need to log in before you can comment on or make changes to this bug.