Bug 973290 - Maven provides are wrong
Maven provides are wrong
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: antlr3 (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 11:56 EDT by Orion Poplawski
Modified: 2014-06-20 02:48 EDT (History)
4 users (show)

See Also:
Fixed In Version: 3.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-18 04:12:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2013-06-11 11:56:15 EDT
Description of problem:

antlr3-java provides mvn(org.antlr:antlr), but that is not sufficient to be able to resolve it because the antlr3.jar is in antlr3-tools.

Version-Release number of selected component (if applicable):
antlr3-java-0:3.4-14.fc19.noarch
Comment 1 Mikolaj Izdebski 2013-06-11 12:17:32 EDT
Thank you for the report.  In near future, after implementing feature from bug #973304, packages with bugs like this are going to fail to build.
Comment 2 Mikolaj Izdebski 2014-06-18 04:08:41 EDT
Fixed in antlr3-3.5-1
Comment 3 Mikolaj Izdebski 2014-06-18 04:12:09 EDT
I believe that this bug is fixed in antlr3-3.5-1,
which is available in Fedora Rawhide, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=538700

This bug was fixed in the next release of Fedora, and is not planned
to be fixed in the release it was filed against.  If you want this bug
to be fixed in updates for Fedora 19, please say so in a comment.
Otherwise you can update to the newer release of Fedora to get the fix.
Comment 4 Orion Poplawski 2014-06-19 11:28:30 EDT
This update broke the upgrade path for the antlr3-C sub-package which uses a different version number.
Comment 5 Mikolaj Izdebski 2014-06-20 02:48:35 EDT
(In reply to Orion Poplawski from comment #4)
> This update broke the upgrade path for the antlr3-C sub-package which uses a
> different version number.

Thanks for letting us know.  I believe that this was already fixed in git, but the package didn't build for some reason.

Note You need to log in before you can comment on or make changes to this bug.