Bug 973300 - Installation steps for vagrant not working on Mac (OS X 10.8.3)
Installation steps for vagrant not working on Mac (OS X 10.8.3)
Status: CLOSED WORKSFORME
Product: OpenShift Origin
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
x86_64 Mac OS
unspecified Severity medium
: ---
: ---
Assigned To: N. Harrison Ripps
libra bugs
https://www.openshift.com/wiki/instal...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 12:07 EDT by Steven Fisher
Modified: 2015-05-14 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-12 16:33:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Fisher 2013-06-11 12:07:12 EDT
Description of problem: Following the instructions on this page: https://www.openshift.com/wiki/installing-openshift-origin-using-vagrant-and-puppet

and followed the steps. During vagrant up a number of errors are reported:


Error: Execution of '/bin/yum -d 0 -e 0 -y install openshift-origin-cartridge-mongodb-2.2' returned 1: Error: Package: rubygem-openshift-origin-node-1.10.1-1.git.226.5db356c.fc19.noarch (openshift-origin)
           Requires: ruby(release)
Error: Package: rubygem-openshift-origin-common-1.9.1-1.git.215.babf2d7.fc19.noarch (openshift-origin)
           Requires: ruby(release)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Error: /Stage[main]/Openshift_origin::Node/Package[openshift-origin-cartridge-mongodb-2.2]/ensure: change from absent to present failed: Execution of '/bin/yum -d 0 -e 0 -y install openshift-origin-cartridge-mongodb-2.2' returned 1: Error: Package: rubygem-openshift-origin-node-1.10.1-1.git.226.5db356c.fc19.noarch (openshift-origin)
           Requires: ruby(release)
Error: Package: rubygem-openshift-origin-common-1.9.1-1.git.215.babf2d7.fc19.noarch (openshift-origin)
           Requires: ruby(release)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Notice: /Stage[main]/Openshift_origin/Package[rhc]/ensure: created
Error: Execution of '/bin/yum -d 0 -e 0 -y install openshift-origin-cartridge-jenkins-client-1.4' returned 1: Error: Package: rubygem-openshift-origin-node-1.10.1-1.git.226.5db356c.fc19.noarch (openshift-origin)
           Requires: ruby(release)
Error: Package: rubygem-openshift-origin-common-1.9.1-1.git.215.babf2d7.fc19.noarch (openshift-origin)
           Requires: ruby(release)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

and a number of others.

resulting in:

Failed to issue method call: Unit cgconfig.service failed to load: No such file or directory. See system logs and 'systemctl status cgconfig.service' for details.
Failed to issue method call: Unit cgred.service failed to load: No such file or directory. See system logs and 'systemctl status cgred.service' for details.
Failed to issue method call: Unit openshift-cgroups.service failed to load: No such file or directory. See system logs and 'systemctl status openshift-cgroups.service' for details.
Failed to issue method call: Unit openshift-broker.service failed to load: No such file or directory. See system logs and 'systemctl status openshift-broker.service' for details.
sudo: /usr/sbin/oo-register-dns: command not found


A VM is created and it is possible to logon, although not surprisingly the command rhc setup results in the error:

Unable to connect to the server (Connection refused - connect(2)
(https://broker.example.com:443)). Check that you have correctly specified your
OpenShift server 'https://broker.example.com/broker/rest/api'.


Version-Release number of selected component (if applicable):

Installed:
  kernel.x86_64 0:3.9.4-200.fc18      kernel-devel.x86_64 0:3.9.4-200.fc18  

etc/puppet/modules
└─┬ openshift-openshift_origin (v0.1.10)
  ├── puppetlabs-ntp (v0.3.0)
  └── puppetlabs-stdlib (v4.1.0)

How reproducible:

Just follow the instructions (as of 06/06/2013)

Steps to Reproduce:
1. curl -s https://nodeload.github.com/openshift/puppet-openshift_origin/legacy.tar.gz/master | tar zxf - --strip 1 '**/test' && mv test origin_vagrant
2.cd origin_vagrant ; vagrant up
3.vagrant ssh

Actual results:

ailed to issue method call: Unit cgconfig.service failed to load: No such file or directory. See system logs and 'systemctl status cgconfig.service' for details.
Failed to issue method call: Unit cgred.service failed to load: No such file or directory. See system logs and 'systemctl status cgred.service' for details.
Failed to issue method call: Unit openshift-cgroups.service failed to load: No such file or directory. See system logs and 'systemctl status openshift-cgroups.service' for details.
Failed to issue method call: Unit openshift-broker.service failed to load: No such file or directory. See system logs and 'systemctl status openshift-broker.service' for details.
sudo: /usr/sbin/oo-register-dns: command not found


Expected results:

Origin node set-up and running.


Additional info:
Comment 1 Dan McPherson 2014-03-12 16:27:54 EDT
Harrison,

  Is this still valid?
Comment 2 N. Harrison Ripps 2014-03-12 16:33:59 EDT
I am marking this as closed / worksforme. The vagrant plugin has evolved considerably since June, and the guide referenced in the original report has been replaced with a new one:

http://openshift.github.io/documentation/oo_deployment_guide_vagrant.html

Additional rationale for closing bug: I am currently running a Vagrant-based Origin system from my Mac (OS X 10.9.2) as I write this.

Note You need to log in before you can comment on or make changes to this bug.