Bug 973324 - Netboot: Fedora 18 crashed and drops to OF after initrd.img transfer
Netboot: Fedora 18 crashed and drops to OF after initrd.img transfer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yaboot (Show other bugs)
18
ppc64 All
unspecified Severity high
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
: 973208 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 12:55 EDT by IBM Bug Proxy
Modified: 2013-06-12 01:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 01:45:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 90622 None None None Never

  None (edit)
Description IBM Bug Proxy 2013-06-11 12:55:48 EDT
> cat yaboot.conf
init-message = "\nWelcome to the 64-bit Fedora 18 installer!\nHit <TAB> for boot options.\n\n"
timeout=6000
default=linux

image=/ppc/ppc64/vmlinuz
        label=linux
        initrd=/ppc/ppc64/initrd.img
        read-only
        append=""

OF crash information and full console log

IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM     
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM     
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM     
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM     
IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM IBM     
                                                                                
                                                                                
                                                                                
                                                                                
                                                                                
                                                                                
                                                                                
TFTP BOOT ---------------------------------------------------                   
Server IP.....................9.3.191.33                                        
Client IP.....................9.3.182.115                                       
Gateway IP....................9.3.182.1                                         
Subnet Mask...................255.255.255.0                                     
( 1  ) Filename................./tftpboot/linuxRHELFedora18_GA/yaboot           
TFTP Retries..................5                                                 
Block Size....................512                                               
FINAL PACKET COUNT = 516                                                        
FINAL FILE SIZE = 264060  BYTES                                                 
                                                                                
Elapsed time since release of system processors: 4770 mins 42 secs              
                                                                                
Try to netboot                                                                  
                                                                                
                                                                                
                                                                                
TFTP BOOT ---------------------------------------------------                   
Server IP.....................9.3.191.33                                        
Client IP.....................9.3.182.115                                       
Gateway IP....................9.3.182.1                                         
Subnet Mask...................255.255.255.0                                     
( 1  ) Filename.................\etc\01-e4-1f-13-4f-7f-02                       
TFTP Retries..................5                                                 
Block Size....................512                                               
FINAL PACKET COUNT = 1                                                          
FINAL FILE SIZE = 419  BYTES                                                    
Config file read, 419 bytes                                                     
                                                                                
                                                                                
Welcome to the 64-bit Fedora 18 installer!                                      
Hit <TAB> for boot options.                                                     
                                                                                
                                                                                
Welcome to yaboot version 1.3.17 (Red Hat 1.3.17-6.fc18)                        
Enter "help" to get some basic usage information                                
boot: help                                                                      
                                                                                
Press the tab key for a list of defined images.                                 
The label marked with a "*" is is the default image, press <return> to boot it. 
                                                                                
To boot any other label simply type its name and press <return>.                
                                                                                
To boot a kernel image which is not defined in the yaboot configuration         
file, enter the kernel image name as [[device:][partno],]/path, where           
"device:" is the OpenFirmware device path to the disk the image                 
resides on, and "partno" is the partition number the image resides on.          
Note that the comma (,) is only required if you specify an OpenFirmware         
device, if you only specify a filename you should not start it with a ","       
                                                                                
To boot a alternative initrd file rather than specified in the yaboot           
configuration file, use the "initrd" command on Yaboot's prompt:                
"initrd=[name.img]". This will load the "name.img" file after the default       
kernel image. You can, also, specify a different initrd file to any other       
label of the yaboot configuration file. Just type "label initrd=[name.img]"     
and the specified initrd file will be loaded.                                   
                                                                                
To load an alternative config file rather than /etc/yaboot.conf, enter          
its device, partno and path, on Open Firmware Prompt:                           
boot conf=device:partno,/path/to/configfile                                     
.To reload the config file or load a new one, use the "conf" command            
on Yaboot's prompt:                                                             
conf [device=device] [partition=partno] [file=/path/to/configfile]              
                                                                                
If you omit "device" and "partno", Yaboot will use their current                
values. You can check them by entering "conf" on Yaboot's prompt.               
boot: conf                                                                      
Current configuration:                                                          
device: /pci@80000002000020c/ethernet@0:                                        
partition: auto                                                                 
file: /etc/01-e4-1f-13-4f-7f-02                                                 
boot: prom_dump_memory                                                          
Please wait, loading kernel...                                                  
prom_dump_memory:-1,/vmlinux: Unable to open file, Invalid device               
boot:                                                                           
Please wait, loading kernel...                                                  
                                                                                
                                                                                
                                                                                
TFTP BOOT ---------------------------------------------------                   
Server IP.....................9.3.191.33                                        
Client IP.....................9.3.182.115                                       
Gateway IP....................9.3.182.1                                         
Subnet Mask...................255.255.255.0                                     
( 1  ) Filename.................\tftpboot\linuxRHELFedora18_GA\vmlinuz          
TFTP Retries..................5                                                 
Block Size....................512                                               
FINAL PACKET COUNT = 40200                                                      
FINAL FILE SIZE = 20582016  BYTES                                               
   Elf64 kernel loaded...                                                       
Loading ramdisk...                                                              
                                                                                
                                                                                
                                                                                
TFTP BOOT ---------------------------------------------------                   
Server IP.....................9.3.191.33                                        
Client IP.....................9.3.182.115                                       
Gateway IP....................9.3.182.1                                         
Subnet Mask...................255.255.255.0                                     
( 1  ) Filename.................\tftpboot\linuxRHELFedora18_GA\initrd.img       
TFTP Retries..................5                                                 
Block Size....................512                                               
PACKET COUNT = 51200                                                            
Detected bad memory access to address: 00000000100001ff                         
Package path = /packages/boot-mgr                                               
Loc-code = U78C5.001.WIH1114-P2-C6-T1                                           
FCode version = 170                                                             
Return Stack Trace                                                              
------------------                                                              
c!  - c3e60c                                                                    
move  - c41708                                                                  
(poplocals)  - c3c9e8                                                           
read  - d0a690                                                                  
(poplocals)  - c3c9e8                                                           
catch  - c3aff0                                                                 
$call-method  - c48ca0                                                          
(poplocals)  - c3c9e8                                                           
LOAD  - d65b58                                                                  
catch  - c3aff0                                                                 
$call-method  - c48ca0                                                          
(poplocals)  - c3c9e8                                                           
catch  - c3aff0                                                                 
catch  - d10474                                                                 
invalid pointer - 3ff8                                                          
LOAD  - d35a28                                                                  
catch  - c3aff0                                                                 
$call-method  - c48ca0                                                          
(poplocals)  - c3c9e8                                                           
catch  - c3aff0                                                                 
ramdisk load failed !                                                           
ENTER called ok                                                                 
0 >

The patch to increase yaboot's TFTP buffer size is now pushed upstream (http://git.ozlabs.org/?p=yaboot.git;a=commit;h=f70d675c9b833e57b605fc94702cd66e97c717f5).
Comment 1 Tony Breeds 2013-06-12 01:31:09 EDT
*** Bug 973208 has been marked as a duplicate of this bug. ***
Comment 2 Tony Breeds 2013-06-12 01:45:18 EDT
Build at: http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1164566

Note You need to log in before you can comment on or make changes to this bug.