Bug 973381 - [RHS-C] Traceback: pkg_resources.DistributionNotFound: rhsc-sdk>=2.1.0.0 when running rhsc-shell
[RHS-C] Traceback: pkg_resources.DistributionNotFound: rhsc-sdk>=2.1.0.0 when...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc-cli (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Aravinda VK
Dustin Tsang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 15:48 EDT by Dustin Tsang
Modified: 2015-07-13 00:39 EDT (History)
7 users (show)

See Also:
Fixed In Version: 2.1.0-0.bb3a.el6rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dustin Tsang 2013-06-11 15:48:02 EDT
Description of problem:

running the shell command rhsc-shell from the command line yields exception.

Traceback (most recent call last):
  File "/usr/bin/rhsc-shell", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2659, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: rhsc-sdk>=2.1.0.0

Version-Release number of selected component (if applicable):

rhsc-bb3

How reproducible:

100%

Steps to Reproduce:
1.run rhsc-shell from the terminal
2.
3.

Actual results:
Traceback (most recent call last):
  File "/usr/bin/rhsc-shell", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 2659, in <module>
    parse_requirements(__requires__), Environment()
  File "/usr/lib/python2.6/site-packages/pkg_resources.py", line 546, in resolve
    raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: rhsc-sdk>=2.1.0.0

Expected results:
normal rhsc shell prompt is given


Additional info:
Comment 2 Aravinda VK 2013-06-17 01:16:19 EDT
RHSC SDK and CLI regenerate issue, fixed in bb3a.
Comment 3 Matt Mahoney 2013-06-20 13:15:34 EDT
Verified with:
 RHSC: bb4
 VDSM: 4.10.2-22.4
 RHS:  RHS-2.1-20130619
Comment 4 Scott Haines 2013-09-23 18:25:54 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.