Bug 973387 - installing rpms on consumers with 'consumer package install' fails in several ways
installing rpms on consumers with 'consumer package install' fails in several...
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: consumers (Show other bugs)
2.2 Beta
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2.2.0
Assigned To: Michael Hrivnak
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 16:24 EDT by Jeremy Cline
Modified: 2013-09-10 11:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 11:42:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Cline 2013-06-11 16:24:39 EDT
Description of problem: I am unable to use 'pulp-admin rpm consumer package install run' for packages that have dependencies, and it only works on packages with no dependencies if I use 'yum clean all' first. 


Version-Release number of selected component (if applicable): 
pulp-rpm-admin-extensions-2.2.0-0.3.beta.fc18.noarch
pulp-rpm-handlers-2.2.0-0.3.beta.fc18.noarch

How reproducible:


Steps to Reproduce:
1. pulp-admin rpm repo create --repo-id=zoo --feed=http://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/
2. pulp-admin rpm repo sync run --repo-id=zoo
3. pulp-admin rpm consumer bind --consumer-id=jeremy --repo-id=zoo
4. pulp-admin rpm consumer package install run --consumer-id=jeremy --name=bear
5. Repeat step 4.

If 'yum clean all' is used and then step 4 is repeated, the installation is successful.

Actual results:
Step 4 results in 
[-]
Waiting to begin...
Refresh Repository Metadata             [ OK ]
Downloading Packages                    [ FAILED ]

Install Failed

[u'Errors were encountered while downloading packages.', u'bear-4.1-1.noarch:
[Errno 256] No more mirrors to try.']

and the traceback in the server_calls.log is
Traceback (most recent call last):
  File \"/usr/lib/python2.7/site-packages/pulp/agent/lib/dispatcher.py\", line 76, in install
      report = handler.install(conduit, units, dict(options))
      
  File \"/usr/lib/pulp/agent/handlers/rpm.py\", line 99, in install
      details = pkg.install(names)
      
  File \"/usr/lib/python2.7/site-packages/pulp_rpm/handler/rpmtools.py\", line 133, in install
      yb.processTransaction()
      
  File \"/usr/lib/python2.7/site-packages/pulp_rpm/handler/rpmtools.py\", line 559, in processTransaction
      YumBase.processTransaction(self, callback, rpmDisplay=display)\
      
  File \"/usr/lib/python2.7/site-packages/yum/__init__.py\", line 6123, in processTransaction 
     pkgs = self._downloadPackages(callback)
  File \"/usr/lib/python2.7/site-packages/yum/__init__.py\", line 6158, in _downloadPackages
      raise Errors.YumDownloadError, errstr
      
YumDownloadError: [u'Errors were encountered while downloading packages.',  u'bear-4.1-1.noarch: [Errno 256] No more mirrors to try.']"


Step 5 results in
[-]
Waiting to begin...
Refresh Repository Metadata             [ OK ]
Downloading Packages                    [ FAILED ]

Install Failed

DownloadCallback instance has no attribute 'fsize'

and the traceback in the server_calls.log is
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/pulp/agent/lib/dispatcher.py", line 76, in install
    report = handler.install(conduit, units, dict(options))
  File "/usr/lib/pulp/agent/handlers/rpm.py", line 99, in install
    details = pkg.install(names)
  File "/usr/lib/python2.7/site-packages/pulp_rpm/handler/rpmtools.py", line 133, in install
    yb.processTransaction()
  File "/usr/lib/python2.7/site-packages/pulp_rpm/handler/rpmtools.py", line 559, in processTransaction
    YumBase.processTransaction(self, callback, rpmDisplay=display)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 6123, in processTransaction
    pkgs = self._downloadPackages(callback)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 6147, in _downloadPackages
    probs = self.downloadPkgs(dlpkgs)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2333, in downloadPkgs
    urlgrabber.grabber.parallel_wait()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2259, in parallel_wait
    perform()
  File "/usr/lib/python2.7/site-packages/urlgrabber/grabber.py", line 2210, in perform
    opts.progress_obj.start(text=opts.text, now=opts._progress)
  File "/usr/lib/python2.7/site-packages/urlgrabber/progress.py", line 127, in start
    self._do_start(now)
  File "/usr/lib/python2.7/site-packages/pulp_rpm/handler/rpmtools.py", line 466, in _do_start
    package = ' | '.join((self._getName(), self.fsize))
AttributeError: DownloadCallback instance has no attribute 'fsize'


Finally, attempting to install a package with dependencies results in
[jcline@jcline ~]$ pulp-admin rpm consumer package install run --consumer-id=jeremy --name=whale
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...
Refresh Repository Metadata             [ OK ]
Downloading Packages                    [ OK ]
Check Package Signatures                [ OK ]
Running Test Transaction                [ FAILED ]

Install Failed

[u'ERROR with transaction check vs depsolve:', 'shark is needed by
whale-0.2-1.noarch', 'stork is needed by whale-0.2-1.noarch', u'Please report
this error at
https://bugzilla.redhat.com/enter_bug.cgi?product=Fedora&version=rawhide&compone
nt=yum']


Expected results: 
successful installation


Additional info: 
yum would install the packages with dependencies from http://repos.fedorapeople.org/repos/pulp/pulp/demo_repos/zoo/ but not from the local repository. yum would install packages from the local repo without dependencies when 'pulp-admin rpm consumer package install run' failed.
Comment 1 Jeff Ortel 2013-06-13 09:50:52 EDT
Fixing just the "AttributeError: DownloadCallback instance has no attribute 'fsize'"
Comment 2 Jeff Ortel 2013-06-17 16:18:45 EDT
build: 2.2.0-0.4.beta
Comment 3 Preethi Thomas 2013-06-20 14:57:04 EDT
fails-qa

So the fsize issue is resolved

but packages with deps seem to be failing

[root@ibm-x3550m3-13 ~]# pulp-admin rpm consumer package install run --consumer-id test.consumer -n bear
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...
Refresh Repository Metadata             [ OK ]
Downloading Packages                    [ OK ]
Check Package Signatures                [ OK ]
Running Test Transaction                [ OK ]
Running Transaction                     [ OK ]

Install Succeeded

+----------------------------------------------------------------------+
                               Installed
+----------------------------------------------------------------------+

Name:    bear
Version: 4.1
Arch:    noarch
Repoid:  zoo




[root@ibm-x3550m3-13 ~]# pulp-admin rpm consumer package install run --consumer-id test.consumer -n firefox
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...
Refresh Repository Metadata             [ OK ]
Downloading Packages                    [ OK ]
Check Package Signatures                [ OK ]
Running Test Transaction                [ FAILED ]

Install Failed

[u'ERROR with rpm_check_debug vs depsolve:', 'system-bookmarks is needed by
firefox-10.0.5-1.el6_2.x86_64', 'xulrunner >= 10.0.5-1 is needed by
firefox-10.0.5-1.el6_2.x86_64', 'libmozalloc.so()(64bit) is needed by
firefox-10.0.5-1.el6_2.x86_64', 'libstartup-notification-1.so.0()(64bit) is
needed by firefox-10.0.5-1.el6_2.x86_64', 'libxpcom.so()(64bit) is needed by
firefox-10.0.5-1.el6_2.x86_64', 'libxul.so()(64bit) is needed by
firefox-10.0.5-1.el6_2.x86_64', u'Please report this error at
https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux
%206&component=yum']


[root@ibm-x3550m3-13 ~]# pulp-admin rpm consumer package install run --consumer-id test.consumer -n whale
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...
Refresh Repository Metadata             [ OK ]
Downloading Packages                    [ OK ]
Check Package Signatures                [ OK ]
Running Test Transaction                [ FAILED ]

Install Failed

[u'ERROR with rpm_check_debug vs depsolve:', 'shark is needed by
whale-0.2-1.noarch', 'stork is needed by whale-0.2-1.noarch', u'Please report
this error at
https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux
%206&component=yum']


[root@ibm-x3550m3-13 ~]#
Comment 4 Michael Hrivnak 2013-07-03 11:11:55 EDT
https://github.com/pulp/pulp_rpm/pull/270
Comment 5 Michael Hrivnak 2013-08-02 10:23:26 EDT
build: 2.2.0-0.23.beta
Comment 6 Preethi Thomas 2013-08-07 14:42:56 EDT
verified

[root@cloud-qe-14 ~]# pulp-admin rpm consumer package install run --consumer-id consumer1 -n bear
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...
Refresh Repository Metadata             [ OK ]
Downloading Packages                    [ OK ]
Check Package Signatures                [ OK ]
Running Test Transaction                [ OK ]
Running Transaction                     [ OK ]

Install Succeeded

+----------------------------------------------------------------------+
                               Installed
+----------------------------------------------------------------------+

Name:    bear
Version: 4.1
Arch:    noarch
Repoid:  zoo



[root@cloud-qe-14 ~]# pulp-admin rpm consumer package install run --consumer-id consumer1 -n whale
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...
Refresh Repository Metadata             [ OK ]
Downloading Packages                    [ OK ]
Check Package Signatures                [ OK ]
Running Test Transaction                [ OK ]
Running Transaction                     [ OK ]

Install Succeeded

+----------------------------------------------------------------------+
                               Installed
+----------------------------------------------------------------------+

Name:    whale
Version: 0.2
Arch:    noarch
Repoid:  zoo


+----------------------------------------------------------------------+
                       Installed for Dependencies
+----------------------------------------------------------------------+

Name:    shark
Version: 0.1
Arch:    noarch
Repoid:  zoo

Name:    stork
Version: 0.12
Arch:    noarch
Repoid:  zoo



[root@cloud-qe-14 ~]#
Comment 8 Preethi Thomas 2013-08-15 08:57:50 EDT
Failing this again

Looks like this is an issue in Fedora19.

I have a installed pulp on Fedora 19. trying install packages to a consumer fails

[root@hp-dl380pgen8-02-vm-16 ~]# pulp-admin rpm consumer package install run --consumer-id consumer1 --name zsh
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...
Refresh Repository Metadata             [ OK ]
Downloading Packages                    [ OK ]
Check Package Signatures                [ OK ]
Running Test Transaction                [ FAILED ]

Install Failed

[u'ERROR with rpm_check_debug vs depsolve:', 'mesa-dri-filesystem(x86-64) is
needed by (installed) mesa-dri1-drivers-7.11-8.el6.x86_64',
'mesa-dri-filesystem(x86-64) is needed by (installed)
mesa-dri-drivers-9.0-0.7.el6.x86_64', 'perl-Git = 1.7.1-2.el6_0.1 is needed by
(installed) git-1.7.1-2.el6_0.1.x86_64', 'libproxy-python = 0.3.0-3.el6_3 is
needed by (installed) libproxy-0.3.0-3.el6_3.x86_64', 'glibc-headers =
2.12-1.107.el6 is needed by (installed) glibc-devel-2.12-1.107.el6.x86_64',
u'Please report this error at
https://bugzilla.redhat.com/enter_bug.cgi?product=Red%20Hat%20Enterprise%20Linux
%206&component=yum']


[root@hp-dl380pgen8-02-vm-16 ~]#
Comment 9 Preethi Thomas 2013-08-15 13:12:04 EDT
I made a mistake above, bound a i386 repo to x86_64 client.

Works when using the correct repo/ moving back to verified

[root@hp-dl380pgen8-02-vm-16 ~]# pulp-admin rpm consumer package install run --consumer-id consumer1 --name zsh
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...
Refresh Repository Metadata             [ OK ]
Downloading Packages                    [ OK ]
Check Package Signatures                [ OK ]
Running Test Transaction                [ OK ]
Running Transaction                     [ OK ]

Install Succeeded

+----------------------------------------------------------------------+
                               Installed
+----------------------------------------------------------------------+

Name:    zsh
Version: 4.3.10
Arch:    x86_64
Repoid:  rhel6-64



[root@hp-dl380pgen8-02-vm-16 ~]#
Comment 10 Preethi Thomas 2013-09-10 11:42:57 EDT
2.2 released
http://repos.fedorapeople.org/repos/pulp/pulp/stable/2.2/

Note You need to log in before you can comment on or make changes to this bug.